Changes between Version 3 and Version 4 of support-team/wheezy-upgrade-communications


Ignore:
Timestamp:
Nov 12, 2013, 1:40:15 AM (6 years ago)
Author:
Jamie McClelland
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • support-team/wheezy-upgrade-communications

    v3 v4  
    77=== English ===
    88
    9 || In brief: The support team is planning the upgrade of our servers from Debian 6 to Debian 7, which has important implications for your web sites. The people responsible for maintaining your sites should ensure that your web software will be compatible with PHP 5.4. Failure to ensure compatibility may result in your web site failing to work properly. ||
     9|| In brief: The support team is planning the upgrade of our servers from Debian 6 to Debian 7, which has important implications for your web sites. The people responsible for maintaining your sites should ensure that your web software will be compatible with PHP 5.4. Failure to ensure compatibility may result in your web site failing to work properly. For more detailed information, please see https://support.mayfirst.org/wiki/squeeze-wheezy-mosh-upgrade ||
    1010
    1111Greetings May First/People Link Member!
     
    1515Our servers run the Debian GNU/Linux operating systems, which is free software [#ref1en (1)]. The Debian software packages, like in any operating systems, are constantly updated. However, Debian always maintains a "stable" version that only accepts minimal, security-related changes. This stable version is replaced approximately every 2 years. The stable version known as Debian 7 (aka "wheezy") was released on May 3, 2013 and replaced version 6 (aka "squeeze"), which has become obsolete [#ref2en (2)].
    1616
    17 It is imperative for our server administrators to upgrade all our servers and this change has important implication for all members: the upgrade, which will proceed according to the schedule below, includes a change in the version of PHP, a very common web-programming language (from PHP 5.3 to PHP 5.4). Many older web sites programmed in PHP may not properly function with this newer version of the programming language. In particular, web sites running Drupal version 5 or lower will most likely break unless they are first upgraded.
     17It is imperative for our server administrators to upgrade all our servers and this change has important implication for all members: the upgrade, which will proceed according to the schedule below, includes a change in the version of PHP, a very common web-programming language (from PHP 5.3 to PHP 5.4). Many older web sites programmed in PHP may not properly function with this newer version of the programming language. In particular, web sites running Drupal version 5 or lower and Joomla sites running 1.5 or lower will likely break unless they are first upgraded (Drupal 6 sites must have all third party modules updated to the most recent versions, and have the panels module updated to the dev version).
    1818
    1919The support team has written the following calendar for upgrades, based on the name of your primary server (if you do not know the primary server of your web site, please login to the control panel - https://members.mayfirst.org/cp - and look for the label "Your primary host is").
     
    9090=== Spanish ===
    9191
    92 ||En concreto: el equipo de soporte ha programado la actualización del conjunto de servidores, éstos pasarán del Sistema Operativo Debian 6 a Debian 7, lo cual implica que los responsables del mantenimiento de cada sitio web deberán asegurarse de que el software que usan sea compatible con PHP 5.4. De lo contrario, sus sitios web se verán afectados y podrían quedar inhabilitados.||
     92||En concreto: el equipo de soporte ha programado la actualización del conjunto de servidores, éstos pasarán del Sistema Operativo Debian 6 a Debian 7, lo cual implica que los responsables del mantenimiento de cada sitio web deberán asegurarse de que el software que usan sea compatible con PHP 5.4. De lo contrario, sus sitios web se verán afectados y podrían quedar inhabilitados. Para obtener información más detallada, consulte https://support.mayfirst.org/wiki/squeeze-wheezy-mosh-upgrade ||
    9393
    9494Estimad@s miembros, reciban un saludo.
     
    9898Nuestros servidores son operados gracias al Sistema Operativo Debian, el cual es Software Libre (GNU/Linux) [#ref1es (1)]. Los paquetes de software de Debian, como en cualquier Sistema Operativo son constantemente modificados y su plan de desarrollo contempla el mantenimiento a la versión estratégica llamada "estable" que será renovada en el futuro por nuevas ediciones sobre las que ya se trabaja [#ref2es (2)]. La versión estable actual se denomina Debian 7 "Wheezy", la cual fue puesta a disposición el 4 de mayo 2013 y sustituyó a la versión 6 "Squeeze", misma que pasó a ser obsoleta.
    9999
    100 Estos cambios representan para l@s administradores/as de nuestra infraestructura la necesidad imperativa de actualizar todos nuestros servidores y eso tiene implicaciones para tod@s nuestr@s miembros: la actualización que se realizará de acuerdo con la programación anunciada más abajo dejará nuestra infraestructura corriendo en Debian 7 "Wheezy" y pasará de usar PHP 5.3 a PHP 5.4 -éste es un lenguaje muy común de programación para la web-, por lo que todos los sitios web que no puedan usar esta versión de PHP deberán ser actualizados por l@s responsables técnic@s y diseñadores/as a cargo de su mantenimiento. Especial mención debe hacerse de los sitios web que usan Drupal 5 (o versiones anteriores) como gestor de contenidos, pues éstos también están en riesgo de quedar inservibles sino se toman las medidas adecuadas para ser actualizados.
     100Estos cambios representan para l@s administradores/as de nuestra infraestructura la necesidad imperativa de actualizar todos nuestros servidores y eso tiene implicaciones para tod@s nuestr@s miembros: la actualización que se realizará de acuerdo con la programación anunciada más abajo dejará nuestra infraestructura corriendo en Debian 7 "Wheezy" y pasará de usar PHP 5.3 a PHP 5.4 -éste es un lenguaje muy común de programación para la web-, por lo que todos los sitios web que no puedan usar esta versión de PHP deberán ser actualizados por l@s responsables técnic@s y diseñadores/as a cargo de su mantenimiento. Especial mención debe hacerse de los sitios web que usan Drupal 5 y Joomla 1.5 (o versiones anteriores) como gestor de contenidos, pues éstos también están en riesgo de quedar inservibles sino se toman las medidas adecuadas para ser actualizados (sitios en Drupal 6 deben tener todos los módulos de terceros actualizados a las versiones más recientes y tienen el módulo de paneles actualizado a la versión dev.)
    101101
    102102El equipo de soporte de Primero de Mayo/Enlace Popular ha programado un calendario de actualizaciones para la infraestructura de servidores que deberá ser considerado por todas las organizaciones y personas miembros que tienen sitios web con las características descritas anteriormente. Los servidores están identificados por su nombre y ustedes pueden verificar cuál de ellos es el que están utilizando al ingresar al panel de control https://members.mayfirst.org/cp y ubicar la mención "Your primary host is"