Changes between Initial Version and Version 1 of support-team/wheezy-upgrade-communications


Ignore:
Timestamp:
Nov 9, 2013, 9:26:46 AM (6 years ago)
Author:
Jamie McClelland
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • support-team/wheezy-upgrade-communications

    v1 v1  
     1= Email Messages regarding the squeeze to wheezy upgrade =
     2
     3See also the [wiki:squeeze-wheezy-mosh-upgrade main squeeze to wheezy upgrade page].
     4
     5== Generic message about upgrade, with list of MOSH'es and the calendar ==
     6
     7=== English ===
     8
     9|| In brief: The support team is planning the upgrade of our servers from Debian 6 to Debian 7, which has important implications for your web sites. The people responsible for maintaining your sites should ensure that your web software will be compatible with PHP 5.4. Failure to ensure compatibility may result in your web site failing to work properly. ||
     10
     11Greetings May First/People Link Member!
     12
     13As part of the process of maintaining our shared infrastructure, it is crucial that we upgrade obsolete software to fix security holes and bugs and introduce new features.
     14
     15Our servers run the Debian GNU/Linux operating systems, which is free software [#ref1en (1)]. The Debian software packages, like in any operating systems, are constantly updated. However, Debian always maintains a "stable" version that only accepts minimal, security-related changes. This stable version is replaced approximately every 2 years. The stable version known as Debian 7 (aka "wheezy") was released on May 3, 2013 and replaced version 6 (aka "squeeze"), which has become obsolete [#ref2en (2)].
     16
     17It is imperative for our server administrators to upgrade all our servers and this change has important implication for all members: the upgrade, which will proceed according to the schedule below, includes a change in the version of PHP, a very common web-programming language (from PHP 5.3 to PHP 5.4). Many older web sites programmed in PHP may not properly function with this newer version of the programming language. In particular, web sites running Drupal version 5 or lower will most likely break unless they are first upgraded.
     18
     19The support team has written the following calendar for upgrades, based on the name of your primary server (if you do not know the primary server of your web site, please login to the control panel - https://members.mayfirst.org/cp - and look for the label "Your primary host is").
     20
     21Saturday, November 2, 2013
     22        * rose
     23
     24Saturday, December 7, 2013
     25        * malcolm
     26
     27Saturday, January 4, 2014
     28        * albizu
     29        * annapurna
     30        * annette
     31        * barghouti
     32        * binh
     33        * boggs
     34        * brown
     35        * buffy
     36        * chavez
     37        * clara
     38        * colin
     39        * daza
     40        * debs
     41        * didier
     42        * dorothy
     43        * eagle
     44        * foucault
     45        * gaspar
     46        * goldman
     47        * hammer
     48        * julia
     49        * june
     50        * kahlo
     51        * kerr
     52        * kinoy
     53
     54Saturday, February 1, 2014
     55        * lucy
     56        * lumumba
     57        * magon 
     58        * mandela
     59        * marx
     60        * menchu
     61        * molina
     62        * proudhon
     63        * rivera
     64        * rodolpho
     65        * roe
     66        * rose
     67        * rushdie
     68        * slaapbeen
     69        * sojourner
     70        * stokely
     71        * stone
     72        * stoney
     73        * tresca
     74        * viewsic
     75        * wolf
     76        * yippie
     77        * yser
     78
     79Those members unable to upgrade your web site according to this schedule, may ask the support team to move your site to a server that will maintain an older version of PHP through August 2014 by opening a ticket at https://support.mayfirst.org/newticket.
     80
     81Notes
     82 [=#ref1en 1]. If you would like to learn more about the Debian GNU/Linux operating system, please visit: http://www.debian.org/intro/about.en.html You may be especially interested in the social contract: http://www.debian.org/social_contract.en.html
     83 [=#ref2en 2]. If you would like to learn more about the Debian upgrade process, please see: http://www.debian.org/releases/index.en.html
     84
     85Sincerely[[BR]]
     86Support Team[[BR]]
     87May First/People Link
     88
     89=== Spanish ===
     90
     91||En concreto: el equipo de soporte ha programado la actualización del conjunto de servidores, éstos pasarán del Sistema Operativo Debian 6 a Debian 7, lo cual implica que los responsables del mantenimiento de cada sitio web deberán asegurarse de que el software que usan sea compatible con PHP 5.4. De lo contrario, sus sitios web se verán afectados y podrían quedar inhabilitados.||
     92
     93Estimad@s miembros, reciban un saludo.
     94
     95Como parte del proceso continuo de mantenimiento a la infraestructura compartida de servidores de nuestra asociación es imprescindible renovar el software obsoleto por razones de seguridad y también para incorporar correcciones y mejoras.
     96
     97Nuestros servidores son operados gracias al Sistema Operativo Debian, el cual es Software Libre (GNU/Linux) [#ref1es (1)]. Los paquetes de software de Debian, como en cualquier Sistema Operativo son constantemente modificados y su plan de desarrollo contempla el mantenimiento a la versión estratégica llamada "estable" que será renovada en el futuro por nuevas ediciones sobre las que ya se trabaja [#ref2es (2)]. La versión estable actual se denomina Debian 7 "Wheezy", la cual fue puesta a disposición el 4 de mayo 2013 y sustituyó a la versión 6 "Squeeze", misma que pasó a ser obsoleta.
     98
     99Estos cambios representan para l@s administradores/as de nuestra infraestructura la necesidad imperativa de actualizar todos nuestros servidores y eso tiene implicaciones para tod@s nuestr@s miembros: la actualización que se realizará de acuerdo con la programación anunciada más abajo dejará nuestra infraestructura corriendo en Debian 7 "Wheezy" y pasará de usar PHP 5.3 a PHP 5.4 -éste es un lenguaje muy común de programación para la web-, por lo que todos los sitios web que no puedan usar esta versión de PHP deberán ser actualizados por l@s responsables técnic@s y diseñadores/as a cargo de su mantenimiento. Especial mención debe hacerse de los sitios web que usan Drupal 5 (o versiones anteriores) como gestor de contenidos, pues éstos también están en riesgo de quedar inservibles sino se toman las medidas adecuadas para ser actualizados.
     100
     101El equipo de soporte de Primero de Mayo/Enlace Popular ha programado un calendario de actualizaciones para la infraestructura de servidores que deberá ser considerado por todas las organizaciones y personas miembros que tienen sitios web con las características descritas anteriormente. Los servidores están identificados por su nombre y ustedes pueden verificar cuál de ellos es el que están utilizando al ingresar al panel de control https://members.mayfirst.org/cp y ubicar la mención "Your primary host is"
     102
     103Sábado 2 de noviembre de 2013
     104        * rose
     105
     106Sábado 7 de dicienmbre de 2013
     107        * malcolm
     108
     109Sábado 4 de enero de 2014
     110        * albizu
     111        * annapurna
     112        * annette
     113        * barghouti
     114        * binh
     115        * boggs
     116        * brown
     117        * buffy
     118        * chavez
     119        * clara
     120        * colin
     121        * daza
     122        * debs
     123        * didier
     124        * dorothy
     125        * eagle
     126        * foucault
     127        * gaspar
     128        * goldman
     129        * hammer
     130        * julia
     131        * june
     132        * kahlo
     133        * kerr
     134        * kinoy
     135
     136Sábado 1o de febrero de 2014
     137        * lucy
     138        * lumumba
     139        * magon 
     140        * mandela
     141        * marx
     142        * menchu
     143        * molina
     144        * proudhon
     145        * rivera
     146        * rodolpho
     147        * roe
     148        * rose
     149        * rushdie
     150        * slaapbeen
     151        * sojourner
     152        * stokely
     153        * stone
     154        * stoney
     155        * tresca
     156        * viewsic
     157        * wolf
     158        * yippie
     159        * yser
     160
     161Aquell@s miembros que no puedan actualizar sus sitios web de acuerdo con este calendario, podrán solicitar que éstos sean trasladados a un servidor que mantendrá versiones anteriores de PHP hasta agosto de 2014 vía https://support.mayfirst.org/newticket.
     162
     163NOTAS:
     164 [=#ref1es 1]. Si desean conocer un poco más sobre Debian les recomendamos visitar http://www.debian.org/intro/about.es.html. De especial interés es el Contrato Social que da impulso a este proyecto: http://www.debian.org/social_contract.es.html
     165 [=#ref2es 2]. Pueden conocer un panorama introductorio sobre la lógica de desarrollo de Debian en http://www.debian.org/releases/index.es.html
     166
     167Atentamente[[BR]]
     168Equipo de soporte[[BR]]
     169Primero de Mayo/Enlace Popular
     170
     171== Direct message to members running older versions of Drupal ==
     172
     173=== English ===
     174
     175Dear Member,
     176
     177By now you should have received a notice about the upcoming upgrade of our servers from Debian 6 to Debian 7. If you haven't read about that upgrade, please review the following Lowdown: [link coming].
     178
     179We are contacting you because we detected one or more web sites assigned to your membership that are running a version of Drupal that we expect will break during the upgrade:
     180
     181[List of servers + primary host they are on]
     182
     183It is ''imperative'' that you upgrade these sites prior to the date that your server is scheduled to be upgrade. Failure to do so may result in your web site being broken.
     184
     185The upgrades will begin in December and run through February. For a list of each server and the date it will be upgraded, please see: https://support.mayfirst.org/wiki/squeeze-wheezy-mosh-upgrade
     186
     187If you need more time to upgrade your site, please open a support ticket at https://support.mayfirst.org/newticket requesting that your site be moved to a server running an older version of PHP, that will be maintained through August 2014.
     188
     189In solidarity,
     190
     191Support Team
     192May First/People Link
     193
     194=== Spanish ===
     195
     196Estimad@ miembro de Primero de Mayo/Enlace Popular
     197
     198En este momento debes haber recibido una notificación acerca de la próxima actualización de nuestros servidores, proceso que les hará pasar de Debian 6 a Debian 7. Si no has leído acerca de dicha actualización, por favor revisa el anuncio dado a conocer a través de Lowdown en: [link]
     199
     200Nos ponemos en comunicación contigo pues hemos detectado que uno o más sitios web en operación bajo tu membresía se encuentran ejecutando una versión de Drupal que está obsoleta, lo que implicará que después de la actualización éstos quedarán deshabilitados:
     201
     202[List of servers + primary host they are on]
     203
     204Es ''imperativo'' que actualices este sitio o sitios antes de la fecha en el que el servidor que ocupas sea actualizado, de lo contrario su operación podría fallar.
     205
     206La actualización a servidores iniciará en diciembre y concluirá en febrero. Para conocer la fecha en la que cada servidor será actualizado puedes visitar: https://support.mayfirst.org/wiki/squeeze-wheezy-mosh-upgrade
     207
     208Si necesitas más tiempo para actualizar tu sitio o sitios, por favor inicia una solicitud de asistencia en https://support.mayfirst.org/newticket y pide que tu sitio web sea movido a un servidor que mantendrá una versión antigua de PHP hasta agosto de 2014.
     209
     210Solidariamente[[BR]]
     211Equipo de soporte[[BR]]
     212Primero de Mayo/Enlace Popular