wiki:stretch-buster-upgrade

Version 17 (modified by Jamie McClelland, 9 months ago) (diff)

--

Stretch to Buster Upgrade

Notes and issues are tracked via #15136

Upgrade

These are the general steps if you are NOT upgrading a MOSH (see below for MOSH's), but please read this full page before starting!

rm /etc/apt/sources.list.d/*
rm /etc/apt/preferences.d/*
sed -i "s/stretch/buster/" /etc/apt/sources.list
apt update
apt dist-upgrade
freepuppet-run
freepuppet-run # again
apt dist-upgrade # again
shutdown -h now # or shutdown -r now for physical hosts

Upgrading a mosh

Run: mf-dist-upgrade-mosh

It will warn you about problems and try to run the entire upgrade with minimal intervention.

Prompted config files

The following files may pop up as modified. Always take the package maintainers version (puppet will handle any changes).

If a conf file pops up that is not on this list, you'll have to figure out yourself if we need to preserve it or take the package maintainers version (always prefer package maintainer)

  • /etc/logrotate.d/apache2
  • /etc/systemd/journald.conf
  • /etc/systemd/timesyncd.conf
  • /etc/cronttab
  • /etc/logrotate.conf
  • /etc/ssh/sshd_config
  • /etc/default/postfwd
  • /etc/default/spamassassin

Physical Servers

All kvm guests with a scsi disk must have their /etc/kvm-manager/<GUEST>/env file edited and HDB_DRIVER=scsi should be changed to HDB_DRIVER=scsi-hd (see our 15177 and upstream).