Changes between Version 28 and Version 29 of squeeze-wheezy-mosh-upgrade


Ignore:
Timestamp:
Nov 23, 2013, 6:55:43 PM (6 years ago)
Author:
Jamie McClelland
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • squeeze-wheezy-mosh-upgrade

    v28 v29  
    1010The most significant change during this upgrade is the change from PHP version 5.3 to PHP 5.4. PHP is a programming language used by many programs that run web sites, such as Drupal, Joomla and WordPress. Older versions of these programs may not work properly under the newer version of PHP. If you are running Drupal, WordPress, Joomla or any web application that is running under PHP and you are not sure if you are running a compatible version, please check-in with your technical advisors or post a [/newticket ticket on our support system] to ask us to investigate and offer advice.
    1111
    12 We expect Drupal sites running Drupal 5 or earlier and Joomla sites running 1.5 or earlier to break after this upgrade. Please take this time to upgrade your sites to a more recent version prior to the upgrade.
     12We expect ''Drupal'' sites running Drupal 5 or earlier and ''Joomla'' sites running 1.5 or earlier to break after this upgrade. Please take this time to upgrade your sites to a more recent version prior to the upgrade.
    1313
    14 In addition, if you are running Drupal 6, you must ensure that all your third party modules are upgraded to the most recent versions. In addition, the following third party modules are known to have problems with PHP 5.4:
     14If you are running Drupal 6, you must ensure that all your third party modules are upgraded to the most recent versions. In addition, the following third party modules are known to have problems with PHP 5.4:
    1515
    1616 * [DrupalModule:panels]: If you are running panels you must upgrade to the dev version (6.x-3.x-dev, 2013-10-01). 6.x-3.10 will break.
    1717 * [DrupalModule:draggableviews]: If you are running draggableviews, you must upgrade to the dev version (6.x-3.5+5-dev, 2013-Sep-30). Version 6.x-3.5 will break.
    1818
    19 If you are running CiviCRM, please upgrade to 4.1 (ideally, which should take care of all problems) or 4.3.8 which needs a small patch (documented in comment:9:ticket:8049) if you are using the CiviCRM views module. You may be able to succesfully run earlier versions of CiviCRM, but you will need to add `error_reporting(0);` to your civicrm.settings.php file to avoid PHP strict warnings.
     19If you are running ''CiviCRM'', please upgrade to 4.1 (ideally, which should take care of all problems) or 4.3.8 which needs a small patch (documented in comment:9:ticket:8049) if you are using the CiviCRM views module. You may be able to succesfully run earlier versions of CiviCRM, but you will need to add `error_reporting(0);` to your civicrm.settings.php file to avoid PHP strict warnings.
    2020
    2121== Why are we making this change? ==