Changes between Version 17 and Version 18 of squeeze-wheezy-mosh-upgrade


Ignore:
Timestamp:
Nov 12, 2013, 1:23:55 AM (6 years ago)
Author:
Jamie McClelland
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • squeeze-wheezy-mosh-upgrade

    v17 v18  
    22= Upgrade MOSHES from Squeeze to Wheezy =
    33
    4 The support team is planning the upgrade of our servers from Debian 6 to Debian 7, which has important implications for member web sites. The people responsible for maintaining MF/PL member sites should ensure that your web software will be compatible with PHP 5.4. Failure to ensure compatibility may result in your web site failing to work properly.
     4The support team is planning the upgrade of our servers from Debian 6 (squeezy) to Debian 7 (wheezy), which has important implications for member web sites. All members will need to ensure that your web software will be compatible with PHP 5.4. Failure to ensure compatibility may result in your web site failing to work properly.
    55
    66This wiki page documents the information members need to know, including the schedule for upgrading our MOSH servers from squeeze to wheezy and the communications we plan to have with members regarding this transition. You may also be interested in [wiki:support-team/wheezy-upgrade-tech-notes our technical notes] of the upgrade process. We also have a [wiki:support-team/wheezy-upgrade-communications communications page with our drafted email notifications].
     
    88== What do I need to do to prepare for the upgrade? ==
    99
    10 The most significant change during this upgrade is the change from PHP version 5.3 to PHP 5.4. PHP is a programming language used by many programs that run web sites, such as Drupal, Joomla and WordPress. Older versions of these programs may not work properly under the newer version of PHP. If you are running Drupal, WordPress, Joomla or any web application that is running under PHP and you are not sure if you are running a compatible version, please check-in with your technical advisories or post a [/newticket tiket on our support system] to ask us to investigate and offer advice.
     10The most significant change during this upgrade is the change from PHP version 5.3 to PHP 5.4. PHP is a programming language used by many programs that run web sites, such as Drupal, Joomla and WordPress. Older versions of these programs may not work properly under the newer version of PHP. If you are running Drupal, WordPress, Joomla or any web application that is running under PHP and you are not sure if you are running a compatible version, please check-in with your technical advisors or post a [/newticket tiket on our support system] to ask us to investigate and offer advice.
    1111
    1212We expect Drupal sites running Drupal 5 or earlier and Joomla sites running 1.5 or earlier to break after this upgrade. Please take this time to upgrade your sites to a more recent version prior to the upgrade.