Changes between Version 1 and Version 2 of members/GRIP-UQAM/Debian


Ignore:
Timestamp:
Jan 12, 2017, 3:40:52 PM (3 years ago)
Author:
https://id.mayfirst.org/gripuqam
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • members/GRIP-UQAM/Debian

    v1 v2  
     1[[PageOutline]]
    12* [WikiPedia:Debian]
     3= Berkeley DB =
     4* [WikiPedia:Berkeley_DB], [Wikipedia:Dbm]
     5* A version 6 exists [http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/downloads/index.html oracle.com] but is not in Debian [DebianPackage:libdb5.3] apparently due to a licence issue.
     6* Some Open Source Software use now lmdb [WikiPedia:Lightning_Memory-Mapped_Database] instead.
     7* PHP uses
     8 * Berkeley DB version 2-5 [http://php.net/manual/en/dba.requirements.php php.net] or
     9 * gdbm [ftp://ftp.gnu.org/pub/gnu/gdbm/ GNU database manager] https://qa.debian.org/popcon.php?package=gdbm,
     10 * qdbm [http://fallabs.com/qdbm/index.html fallabs.com] https://qa.debian.org/popcon.php?package=qdbm,
     11 * tcadb [http://fallabs.com/tokyocabinet/ Tokyo Cabinet at Fallabs.com] https://qa.debian.org/popcon.php?package=tokyocabinet,
     12 * Not yet lmdb but a binding is available at [https://github.com/mpremus/lmdb-php mpremus/lmdb-php] [Google:lmdb-php+site:debian.org] https://qa.debian.org/popcon.php?package=lmdb
     13* Conclusion: There are enough replacements for BDB, we can continue to use it!