wiki:faq/drupal/support-timeline

Version 3 (modified by Daniel Kahn Gillmor, 13 years ago) (diff)

--

Drupal Support Timeline

May First/People Link's shared Drupal installation currently supports Drupal versions 4.6, 4.7 and 5. We cannot support all of these version indefinitely. Here's our plan for support of old versions of Drupal

Drupal 4.6

Drupal 4.6 should be phased out as soon as possible. It has not been supported upstream for many months (as of March 2008 -- i can't find the end-of-life announcement to link, though), and despite the backported security fixes from openflows probably contains outstanding vulnerabilities. I recommend helping people upgrade their old 4.6 versions to 4.7 at least.

Drupal 4.7

Drupal 4.7 appears to have been dropped by upstream as well, since 6.1 is "stable" (as of 2008-02-27) and upstream's policy is:

Supported versions for security patches and availability for download are the current stable release and one version previous.

MF/PL should phase drupal 4.7 out no later than the end of 2008, probably earlier.

Drupal 5

Drupal 6