Opened 4 years ago

Closed 4 years ago

#9947 closed Bug/Something is broken (fixed)

Thunderbird worked, then it didn't

Reported by: https://id.mayfirst.org/mleger Owned by: https://id.mayfirst.org/ross
Priority: Medium Component: Tech
Keywords: thunderbird, webmail, iphone Cc: https://id.mayfirst.org/srevilak
Sensitive: no

Description (last modified by https://id.mayfirst.org/mleger)

Yesterday I set up Thunderbird as my email reader. It worked great for about an hour. I can still download messages. But when it sends, it asks me for my password. I enter the correct password, and it tells me it's wrong. BTW, I was able to send messages for about an hour, then I couldn't.

Change History (18)

comment:1 Changed 4 years ago by https://id.mayfirst.org/mleger

  • Description modified (diff)

BTW, I was able to send for about an hour, then I couldn't.

comment:2 Changed 4 years ago by https://id.mayfirst.org/dskallman

  • Keywords thunderbird added
  • Owner set to https://id.mayfirst.org/dskallman
  • Status changed from new to assigned

Hi,

There should have been a checkbox on the setup pages to save passwords as shown here: https://support.mayfirst.org/wiki/faq/email/setup-thunderbird

If you did not select those, you'll have to go remove the current password and re-add by going to Edit > Preferences on the pop-up window select the Security icon & the passwords tab within that & click on Saved Passwords.

Click on the username linked to the mail.mayfirst.org settings and remove. You should be access to add a password again and select the checkbox that says save password.

Let us know if that resolves it. If not, has there been any password change between setup & now.

Thanks,

Dana

comment:3 Changed 4 years ago by https://id.mayfirst.org/mleger

Ok, I deleted the saved passwords. Then when I go to add a new password, I get the message "incoming mail server already exists"

comment:4 Changed 4 years ago by https://id.mayfirst.org/dskallman

Hmmm, I think this is under Edit > Account Settings. You shouldn't be setting up a new account, just editing the existing.

comment:5 Changed 4 years ago by https://id.mayfirst.org/mleger

There is no Edit > Account Settings in my version of Thunderbird. There is Tools > Account Settings, with no obvious way to edit passwords.

I have to get ready for a meeting, but this afternoon I will try removing the account and adding it back. In the meantime, you might want to look at the latest version of Thunderbird for Mac. I notice that your screenshots are a bit out-of-date.

BTW, I had the same problem earlier this year with MacMail. I gave up and started using RoundCube. But the search function on RoundCube is terrible. And I keep coming back to the fact that both Thunderbird and MacMail worked at first, and then stopped. Why would that be the case?

Peace.

Mark

comment:6 Changed 4 years ago by https://id.mayfirst.org/mleger

Hi, this is really up and down. I sent three emails this morning using Thunderbird, no problem. And now I can't. I get caught in the same loop of the program asking me for my password, I type it in, it rejects it.

Also, I can't send Mayfirst mail on my Iphone. It receives ok, but I get caught in the password loop when I try to send something.

Finally, Roundcube is up and down. Sometimes when I try to send, I get the message that there is a conflict with the SMTP server.

Mayfirst, I am happy to come to your office with my laptop if you want to see for yourself.

comment:7 Changed 4 years ago by https://id.mayfirst.org/dskallman

  • Keywords webmail iphone added
  • Owner changed from https://id.mayfirst.org/dskallman to https://id.mayfirst.org/ross

Hi Mark,

There were some issues reported that were resolved last night noted in ticket #9951, let us know if that resolves the issues you've been experiencing too.

I am also looping Ross in to provide any more information that could be causing these issues.

Thanks,

Dana

comment:8 Changed 4 years ago by https://id.mayfirst.org/ross

Hi Mark,

I don't see anything in the logs to suggest why you might be experiencing this weird behavior, nor am I sure why it would work and then stop working. My first thought is that it has to with too many imap connections on malcolm. This is speculation, but it might be the case.

I'd be curious to know if this problem occurs during the weekend and/or at night. This shouldn't have anything to do with your actual password failing, but it could produce strange behavior for Thunderbird.

Sorry I can't give you a more definitive answer, but this is a weird intermittent problem, which is the most difficult to diagnose. Any further information you might be able to add, like when the problem occurs could help.

~/ross

comment:9 Changed 4 years ago by https://id.mayfirst.org/mleger

Hi Ross,

Sorry - I took the weekend off, and yesterday was too busy to deal with this. And I'm feeling really up the proverbial creek now. Service continues to be intermittent. Thunderbird no longer works, and now neither does Roundcube. I sent some messages via Roundcube both yesterday and earlier today. Now when I try to send, I get a message "Error occurred! SMTP Error (535): Authentication failed." So now I can't send email at all.

comment:10 Changed 4 years ago by https://id.mayfirst.org/ross

  • Cc https://id.mayfirst.org/srevilak added

Hi Mark,

I'm really sorry this is happening. I'm going to ask Steve to have a look at roundcube, since he's a roundcube expert. I am seeing the failures you describe:

[07-Aug-2014 15:30:18 -0400]: IMAP Error: Login failed for mleger from xxx.xxx.xxx.203. LOGIN: failed: Could not determine server in /srv/roundcube/program/lib/Roundcube/rcube_imap.php on line 184 (GET /?_task=mail&_action=getunread&_remote=1&_unlock=0&_=1407439814888)
[12-Aug-2014 17:15:10 -0400]: IMAP Error: Login failed for mleger from xxx.xxx.xxx.221. LOGIN: failed: Could not determine server in /srv/roundcube/program/lib/Roundcube/rcube_imap.php on line 184 (POST /?_task=mail&_action=refresh?_task=&_action=)

Unfortunately, I cannot determine what would be causing the problem other than a mis-entered password. My email account is also on malcolm, and I can send messages through roundcube without any issues.

I suspect solving the roundcube problem will also resolve the Thunderbird problem. Hopefully Steve can give us some insight.

~/ross

comment:11 Changed 4 years ago by https://id.mayfirst.org/mleger

Ok, Ross. But we've eliminated wrong password as an issue, right? Roundcube just asks for the passwords once, on log-in -- like Gmail. If I entered the wrong password, I wouldn't even be able to view my mail. But I can.

comment:12 Changed 4 years ago by https://id.mayfirst.org/ross

Hi Mark,

I wasn't making the claim that you've entered the wrong password, just that I'm at a loss as to what else it would be... :-( It's an extremely unusual situation.

~/ross

comment:13 Changed 4 years ago by https://id.mayfirst.org/mleger

Hi Ross, sorry if I'm coming off as testy. I know y'all are doing what you can.

comment:14 Changed 4 years ago by https://id.mayfirst.org/srevilak

I haven't had any MF/PL IMAP or SMTP difficulties during the last few days. I also have no trouble sending mail with roundcube.

Skimming over #mayfirst IRC messages from this afternoon, I see one other member having password problems with SMTP authentication.

mleger's mailbox lives on malcolm. The aforementioned member from IRC has mail hosted on chelsea. Different primary hosts.

Let's look at our two mail.mayfirst.org hosts.

gil: I see successful logins and imap transfers from mleger, along with two SMTP SASL logins from stallman (i.e., roundcube).

paulo: Here's an odd bit. mleger's shadow entry doesn't match the ones on gil and malcolm. More specifically, it's a type $1$ entry, rather than a type $6$ entry.

Also, paulo:/var/log/auth.log has

Sep  3 12:47:19 paulo saslauthd[7689]: do_auth         : auth failure: [user=mleger] [service=smtp] [realm=paulo.mayfirst.org] [mech=shadow] [reason=Unknown]
Sep  3 12:47:19 paulo saslauthd[7685]: do_auth         : auth failure: [user=mleger] [service=smtp] [realm=paulo.mayfirst.org] [mech=shadow] [reason=Unknown]

Perhaps this is why the problem is intermittent: gil and malcolm having one shadow hash while paulo has another?

On paulo, I've replaced mleger's type $1$ shadow hash with his type $6$ hash. I'd be curious to know if this makes a difference.

Last edited 4 years ago by https://id.mayfirst.org/srevilak (previous) (diff)

comment:15 Changed 4 years ago by https://id.mayfirst.org/mleger

Ok, I tested sending emails both through Roundcube and Thunderbird. Successful both times. My fingers are crossed that this sticks.

comment:16 Changed 4 years ago by https://id.mayfirst.org/ross

Thank you Steve. I looked deeper into paulo and it seems that there was a lock file preventing the script mf-sync-users:

-rw-r--r-- 1 root     root        0 Aug 18 07:15 mf-sync-users.lock

I removed the lock file and ran:

0 paulo:/etc/cron.d# rm /var/run/mf-sync-users.lock 
rm: remove regular empty file `/var/run/mf-sync-users.lock'? y
0 paulo:/etc/cron.d# SSH_AUTH_SOCK=/root/.ssh-agent-socket/sock /usr/local/sbin/mf-sync-users
0 paulo:/etc/cron.d#

Everyone's passwords should be synced now. This may help resolve #9955 .

~/ross

comment:17 Changed 4 years ago by https://id.mayfirst.org/srevilak

  • Resolution set to fixed
  • Status changed from assigned to feedback

Ross -- seems very likely that lock file was the root cause.

mleger -- I'm going move this ticket into feedback state. Please let us know if the mail login problems reappear. Otherwise, this ticket will close itself in a few days.

Steve

comment:18 Changed 4 years ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.