Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9801 closed Bug/Something is broken (fixed)

Unable to login to webmail

Reported by: https://id.mayfirst.org/alexan Owned by: https://id.mayfirst.org/srevilak
Priority: Urgent Component: Tech
Keywords: roundcube, email, gaspar.mayfirst.org Cc: ross@…
Sensitive: no

Description

I get "login failed" when trying to login to my webmail account, here: https://roundcube.mayfirst.org/. I'm using my alexan2 account, which was working up until yesterday. I'm unable to read my email.

Change History (7)

comment:1 Changed 4 years ago by https://id.mayfirst.org/dskallman

  • Cc ross@… added
  • Keywords roundcube email gaspar.mayfirst.org added
  • Owner set to https://id.mayfirst.org/srevilak
  • Status changed from new to assigned

Hi Alexan,

I am looping Steve & Ross in to review this. I just tested login into Rouncube with my account at it worked, so I am not sure what the issue could be.

Ross I tried using mf-find-email-to & mf-find-email-from and am getting a command not found, so not sure what could be the issue there.

Dana

comment:2 Changed 4 years ago by https://id.mayfirst.org/ross

Hi Alexan,

I'm not seeing any failed attempts or any login attempts for you from today. Like Dana, I too am able to login to roundcube. This is rather perplexing, are you sure you are entering your password correctly?

~/ross

comment:3 Changed 4 years ago by https://id.mayfirst.org/alexan

I'm trying to log with the prompt at https://roundcube.mayfirst.org/ by entering alexan2 for "Username" and my password (which hasn't changed) for "Password". The message I get below the login prompt is "Loading..." and then "Login failed." So just to be clear, you're not seeing failed login attempts for username alexan2?

comment:4 Changed 4 years ago by https://launchpad.net/~jeremyb

See also #9800.

comment:5 Changed 4 years ago by https://id.mayfirst.org/srevilak

Start by checking paulo (209.234.253.240).

  • User account for alexan2 exists.
  • /etc/perdition/popmap has alexan2 => gaspar mapping
  • no mention of alexan2 in /var/log/*

Next check, gil (216.66.23.48)

  • User account for alexan2 exists
  • /etc/perdidion/popmap for alexan2 => gaspar exists
  • I see mail smtp authentications at Jul 17 12:14:56, but nothing since

#9800 comment 3 notes a specific tls fingerprint. Verified that this matches the mail.mayfirst.org x509 certificate fingerprint for mail.mayfirst.org. Verified that paulo and gil have the same mail.mayfirst.org certificate.

Verified that alexan2 has the same password hash on gil, paulo, gaspar.

Unfortunately, no clear answer yet. :( Will keep looking.

comment:6 Changed 4 years ago by https://id.mayfirst.org/alexan

  • Resolution set to fixed
  • Status changed from assigned to closed

I can now login, and am closing this ticket. Thanks.

comment:7 Changed 4 years ago by https://id.mayfirst.org/srevilak

Ross found the problem: gaspar's x509 certificate had expired. I missed this in my diagnosis.

alexan: thank you for your patience with this issue. Apologies that we didn't identify the problem sooner.

Steve

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.