Opened 5 years ago

Closed 4 years ago

#9143 closed Bug/Something is broken (fixed)

Search function not working

Reported by: jgarcia@… Owned by: https://id.mayfirst.org/srevilak
Priority: Medium Component: Tech
Keywords: roundcube, search Cc:
Sensitive: no

Description

I use roundcube for my email. I have been trying to use the search function and it gives me an error message "server error: Internal server error"

Change History (8)

comment:1 Changed 5 years ago by https://id.mayfirst.org/dskallman

  • Keywords roundcube added; function removed
  • Owner set to https://id.mayfirst.org/srevilak
  • Status changed from new to assigned

Hi jgarcia,

Thanks for the ticket. Am looping Steve in to help.

Thanks,

Dana

comment:2 Changed 4 years ago by https://id.mayfirst.org/srevilak

I just tried the `search' function on https://roundcube.mayfirst.org, and it seems to be working fine.

Perhaps (hopefully) the internal server error was a transient glitch. I'll see if I can figure out what went wrong.

comment:3 Changed 4 years ago by https://id.mayfirst.org/srevilak

  • Resolution set to fixed
  • Status changed from assigned to feedback

I do see some internal server errors from roundcube searches on April 22nd. Here's an illustration (with redactions).

0.0.0.0 - - [22/Apr/2014:12:22:16 -0400] "GET /?_task=mail&_filter=ALL&_q=******&_headers=subject%2Cfrom%2Cbody&_mbox=INBOX&_action=search&_remote=1&_unlock=loading*****&_=***** HTTP/1.1" 500 890 "https://roundcube.mayfirst.org/?_task=mail&_refresh=1&_mbox=INBOX" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8)"

Appears the Internal server error was caused by FastCGI timeouts. In this case, the IMAP host is viewsic.

Nothing telling on viewsic's mail logs.

Hopefully roundcube has been okay since last Tuesday. Roundcube does run into timeouts (which appear to the user as "Internal Server Errors"). This is an area where we're trying to make improvements.

comment:4 Changed 4 years ago by https://id.mayfirst.org/joleen

  • Resolution fixed deleted
  • Status changed from feedback to assigned

It still is giving me an internal server error. It takes a while, and it does seem like it is timing out. No one on our team is having this problem. Can you go into my account and see what it is I am experiencing?

comment:5 Changed 4 years ago by https://id.mayfirst.org/srevilak

These are some technical notes.

In my earlier assessment, I had the primary host wrong: jolean's mail lives on stone, not viewsic.

I tried to mimic an INBOX text search:

0 stone:.../joleen/Maildir# time find cur -type f -print0 | xargs -0 grep -ci FOOBAR | wc -l
5406
real    3m40.080s
user    2m17.645s
sys     0m5.732s
0 stone:.../joleen/Maildir#

This command line searches for the text "FOOBAR" in each mail message. The output "5406" means that 5406 messages were examined. I don't know how many messages matched, but for the purpose of this exercise, we just needed to go through the exercise of performing the search.

The search took 3 minutes and 40 seconds. I repeated the command; the second attempt took 3 minutes and 6 seconds.

If find | xargs grep took 3+ minutes, I suspect that our IMAP server would take approximately as long. Of course, roundcube's response time is completely dependent on the IMAP server.

comment:6 Changed 4 years ago by https://id.mayfirst.org/srevilak

Hello jgarcia,

I have some good news and some bad news for you. The good news is that I understand why your roundcube searches are timing out. The bad news: the timeouts appear to be caused by the amount of mail in your inbox. Unfortunately, more mail means more time to search through it all :(

I can suggest two things for you to try:

  • Roundcube's search searches whatever folder you have open. If you can move messages out of your inbox, then the searches will go faster (because there will be less mail to search through). This should definitely help.
  • Roundcube gives you a set of "search modifiers" (I'll attach a screenshot, so you can see what I'm referring to). If possible, try to leave "body" and "entire message" unchecked.

If you need help moving messages, let me know and I can work with you on that.

For a large collection of email, you might want to try a traditional email program like Thunderbird.

Thunderbird can cache local copies of your mail messages, which should make searching faster. Thunderbird will also make it easier to move messages around into folders. Using Thunderbird doesn't mean you'll have to give up roundcube; you can use both, and even switch back and fourth between the two.

Steve

comment:7 Changed 4 years ago by https://id.mayfirst.org/srevilak

  • Resolution set to fixed
  • Status changed from assigned to feedback

Hello jgarcia,

It's been a while since we touched base on the roundcube search issues you were having. Have things gotten any better? Did you ever give Thunderbird a try?

comment:8 Changed 4 years ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.