Opened 5 years ago

Last modified 5 years ago

#8537 assigned Bug/Something is broken

Urgent : Site Down

Reported by: https://id.mayfirst.org/uws Owned by: https://id.mayfirst.org/ross
Priority: Urgent Component: Tech
Keywords: drupal fatal-error Cc:
Sensitive: no

Description

hello, on the site ibewlocal488.org we currently see Fatal error: Duplicate entry '51567c562c36d6f53ca3ac9e2f825e04' for key 'PRIMARY' query: INSERT INTO sessions (sid, uid, hostname, timestamp) VALUES ('51567c562c36d6f53ca3ac9e2f825e04', 0, '173.76.107.238', 1393257488) in /home/members/ibewlocal488/sites/ibewlocal488.org/web/includes/database.mysql.inc on line 66

As the site is down could you assist as soon as possible pls?

We did not touch the site over the weekend and all was fine as of fri 2/21. thank you.

Change History (8)

comment:1 Changed 5 years ago by https://id.mayfirst.org/ross

  • Keywords drupal fatal-error added
  • Owner set to https://id.mayfirst.org/ross
  • Status changed from new to assigned

Hi uws,

The problem was that you had no user 0 in your user table. I don't know how you deleted the anonymous user record, but somehow that happened. I ran the following command:

INSERT INTO users (uid, name, mail) VALUES ('0', '', '');

to fix the problem. Just so you know I found the solution to the problem by searching the web with the following values:

drupal Fatal error: Duplicate entry insert into sessions

~/ross

comment:2 Changed 5 years ago by https://id.mayfirst.org/ross

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 5 years ago by https://id.mayfirst.org/uws

Thanks Ross, that's helpful. We still show the site as access denied though...when we log in we can see everything...is there a simple command we can run to flush the cache we believe the next step, but unable to do so from here. Could you do this or point us the way. thanks doug

comment:4 Changed 5 years ago by https://id.mayfirst.org/ross

Ah I do see the "You are not authorized to access this page." message. This seems like a permissions issue to me not a caching issue. I cleared the cache but it did not seem to have an effect.

comment:5 Changed 5 years ago by https://id.mayfirst.org/uws

There is probably a way to rebuild the permissions without crashing the site or losing data? sry we're stumped...

comment:6 Changed 5 years ago by https://id.mayfirst.org/ross

I don't know you could try http://ibewlocal488.org/admin/content/node-settings/rebuild and see if that helps.

~/ross

comment:7 Changed 5 years ago by https://id.mayfirst.org/uws

  • Resolution fixed deleted
  • Status changed from closed to assigned

yes that's what we tried, same issue, content only visible via admin log in. support

comment:8 Changed 5 years ago by https://id.mayfirst.org/ross

Okay, it looks like it's fixed now. I re-saved the permissions page and that seems to have worked.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.