Opened 6 years ago

Closed 5 months ago

#8251 closed Bug/Something is broken (fixed)

Creating hosting order fails if uppercase chars are used for Login name

Reported by: HistoriCUSS Owned by: Ross
Priority: Medium Component: Tech
Keywords: chelsea hosting_order control_panel Cc: historiCUSS
Sensitive: no

Description (last modified by HistoriCUSS)

In trying to create a new hosting order, I added Login name that included uppercase letters. That caused the order entry to fail.

red alerts: Login names can only use letters, number, dashes, periods and underscores. A login name must not exceed 32 characters. You entered: UN2014

2nd alert: Your hosting order was created, but none of the server items were. You may want to delete this hosting order and try again.

I entered the domain name in camelcase and it was allowed, though the process forced it to all lower case.

Obviously a different input code is used for the Login name as it is not accepted at all, causing the order entry to fail.

Since it seems uppercase letters are not allowed in usernames, that should be explained more specifically as a hint/instruction and the error message should reflect it also

I saw a discussion about adding some help and hints to this control panel dialog and heartily support that. I think it was #4130

Attachments (2)

Hosting Order Dialog_02.JPG (96.0 KB) - added by HistoriCUSS 6 years ago.
Hosting Order Dialog_03.JPG (118.5 KB) - added by HistoriCUSS 6 years ago.

Download all attachments as: .zip

Change History (19)

Changed 6 years ago by HistoriCUSS

Attachment: Hosting Order Dialog_02.JPG added

comment:1 Changed 6 years ago by HistoriCUSS

Last edited 6 years ago by HistoriCUSS (previous) (diff)

comment:2 Changed 6 years ago by Stephen Mahood

Upon investigating this, though having no experience with developing the CP (hint do not assign to me ;) ) I tried creating a new hosting order with a similar format to UN2014, i used UN2015, UM2014, TN2014 and all gave the same error, in all those cases the user name is not created. When I tried to create the user accounts in an existing hosting order, it did not give an error, but more importantly it made the user name all lower case un2015, um2014, tn2014 accordingly. It seems that the CP has a bug in creating new hosting orders and not making the capitalized letters lowers case. I hope this helps whoever knows more about the CP code

~mv

comment:3 Changed 6 years ago by HistoriCUSS

Last edited 6 years ago by HistoriCUSS (previous) (diff)

Changed 6 years ago by HistoriCUSS

Attachment: Hosting Order Dialog_03.JPG added

comment:4 Changed 6 years ago by HistoriCUSS

Last edited 6 years ago by HistoriCUSS (previous) (diff)

comment:5 Changed 6 years ago by HistoriCUSS

Summary: hosting order protests Login Name and suggests failurehosting order protests Login Name and suggests failure due to uppercase chars

comment:6 Changed 6 years ago by HistoriCUSS

Summary: hosting order protests Login Name and suggests failure due to uppercase charsCreating hosting order fails if uppercase chars are used for Login name

comment:7 Changed 6 years ago by HistoriCUSS

Description: modified (diff)

comment:8 Changed 6 years ago by HistoriCUSS

Description: modified (diff)

comment:9 Changed 6 years ago by Dana

Owner: set to Ross
Status: newassigned

Looping Ross in on this one too & referencing #8252, as they could be related.

comment:10 Changed 6 years ago by HistoriCUSS

Cc: historiCUSS added

comment:11 Changed 6 years ago by Ross

It seems to me that this is a documentation issue and not a bug. I think the solution is for the documentation to say, "Do not use uppercase letters." That would be my solution to this problem. Is there a reason that this would not be acceptable?

~/ross

comment:12 Changed 6 years ago by HistoriCUSS

the error message is not at all informative as to what was not done by the partial processing of the hosting order or the reason for the error.

I think an advisory to "not use uppercase letters" is needed but is the minimum. It would be better to also make the error message more detailed so the user knows what they did wrong and how to correct it by trying again without having to file a support ticket.

Login names can only use [lowercase] letters, number, dashes, periods and underscores. A login name must not exceed 32 characters. You entered: UN2014 [which contains uppercase letters]

The code for forcing uppercase to lowercase that is used for the domain name might also be copied over, but this would also need to produce a notice that this step was done, to make sure the user is aware of the case change.

Last edited 6 years ago by HistoriCUSS (previous) (diff)

comment:13 Changed 5 years ago by https://id.mayfirst.org/lordbrowne

I'm glad I found this thread. I was failing to create a new hosting order, not realising that a couple of capital letters were to blame. While aware that I'm passing it on to others to sort it out, it would be nice to just have a little notice telling people not to use capital letters in the username.

comment:14 Changed 4 years ago by HistoriCUSS

I inadvertently tested this again yesterday by using uppercase letters and got this error message:

Login names can only use letters, number, dashes, periods and underscores. A login name must not exceed 32 characters. You entered: DmV2106

The simple fix is to edit the error message, make 'number' plural and add 'lowercase' as:

Login names can only use lowercase letters, numbers, dashes, periods and underscores. A login name must not exceed 32 characters. You entered: *

Last edited 4 years ago by HistoriCUSS (previous) (diff)

comment:15 Changed 6 months ago by updater

Sensitive: set

Changed to sensitive as part of leadership decision to make all tickets sensitive.

comment:16 Changed 5 months ago by HistoriCUSS

Sensitive: unset

comment:17 Changed 5 months ago by JaimeV

Resolution: fixed
Status: assignedclosed

The new default behavior is to automatically reduce to lowercase.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.