Opened 5 years ago

Closed 5 years ago

#8028 closed Question/How do I...? (fixed)

File cache_form.MYD filling up a partition on magon.

Reported by: Enrique Rosas Owned by: Jamie McClelland
Priority: High Component: Tech
Keywords: drupal cache_form.MYD cache Cc: marvin@…, apolination@…
Sensitive: no

Description

Hi Dana, After Ross warned us about this partititon being filled up, we found this file to be the reason of the issue: cache_form.MYD, which is part of a drupal database.

0 magon:~# ls -lhaS /var/lib/mysql/ctamlibre_oa_db|head -n 2
total 3.0G
-rw-rw---- 1 mysql mysql 3.0G Nov  6 14:52 cache_form.MYD
0 magon:~#

with mysql I found it had 167 rows. I wonder what could had being inside that table to height that much?

After running "Clear all cache" (Limpiar los datos de la cache, in the spanish version) now the file has only 6 rows, but the operating system does no recognizes this change yet and it still shows 3G of size.

So now I have some questions, hoping you can help us:

Is it that the 6 rows left could have the 3G of information? I wonder if truncating the table -that is deleting all rows- is safe for the drupal installation?

What could we do to update the system information about this file?

Thanks a lot in advance Enrique

Change History (8)

comment:1 Changed 5 years ago by Dana

Resolution: fixed
Status: newclosed

Hi Enrique,

Worked with Jamie to repaired table and seems to have done the trick.

Let us know if it's still an issue for you.

Thanks,

Dana

comment:2 Changed 5 years ago by Enrique Rosas

thanks a lot Dana and Jamie,

for repairing it, did you use some tool like myisamchk

or from mysql shell mysql> REPAIR TABLE cache_form

?

Enrique

comment:3 Changed 5 years ago by Enrique Rosas

Resolution: fixed
Status: closedassigned

comment:4 Changed 5 years ago by Enrique Rosas

Owner: set to Dana

Hola Dana, ¿podrías comentar cómo lo resolvieron? Gracias Enrique

comment:5 Changed 5 years ago by Enrique Rosas

Dana, nos seguimos preguntando ¿cúal fue el procedimiento que siguieron? Gracias Enrique

comment:6 Changed 5 years ago by Dana

Owner: changed from Dana to Jamie McClelland

Disculpe el retraso Enrique, fue Jamie quien lo hizo.

Jamie can you note what you did to repair this table?

Thanks,

Dana

comment:7 Changed 5 years ago by Jamie McClelland

I ran repair table. I think that should do it. Is it not working in this case?

You can also try:

TRUNCATE TABLE cache_form;
REPAIR TABLE cache_form;

Any drupal table that starts with cache_ can be safely truncated.

jamie

comment:8 Changed 5 years ago by Enrique Rosas

Resolution: fixed
Status: assignedclosed

thanks Dana and Jamie! Enrique

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.