Opened 6 years ago

Closed 6 years ago

#6862 closed Bug/Something is broken (fixed)

Mayfirst Activist Calendar Page Not Loading

Reported by: patricia@… Owned by: https://id.mayfirst.org/ross
Priority: Medium Component: Tech
Keywords: drupal-calendar Cc: nicadlw@…
Sensitive: no

Description

The main calendar page isn't loading or taking over a minute to load. http://nycal.mayfirst.org/calendar

Other pages are loading normally, for example: http://nycal.mayfirst.org/upcoming http://nycal.mayfirst.org/node/add/event

Change History (7)

comment:1 Changed 6 years ago by https://id.mayfirst.org/ross

  • Keywords drupal-calendar added; event calendar removed
  • Resolution set to fixed
  • Status changed from new to feedback

Hi Patricia,

I think the problem is that you're running a huge mysql query to get the calendar view to display. One way to improve performance would be to cache the view. If you look up your calendar view, there is a place to configure it to cache the view. This will speed things up considerably. The other way to improve performance is to install and configure the boost module https://drupal.org/project/boost . I personally recommend that everyone using drupal install this module as it's performance boost is unparalleled.

Give one of those options a try and see if they help,

~/ross

comment:2 Changed 6 years ago by https://me.yahoo.com/pea_170#99559

  • Status changed from feedback to closed

Thanks, Ross.

I don't have access to install any modules on that instance. Was just reporting it because it's an issue and I thought that's what I was supposed to do. :)

comment:3 Changed 6 years ago by https://id.mayfirst.org/ross

  • Cc nicadlw@… added
  • Resolution fixed deleted
  • Status changed from closed to assigned

Ha! I didn't know it was you Pea, email addresses get obfuscated in the ticketing system. I thought it was the member reporting. I'm going to re-open this ticket and cc David on it. Maybe he can make the necessary changes.

~/ross

comment:4 Changed 6 years ago by https://id.mayfirst.org/ross

  • Owner set to https://id.mayfirst.org/ross

comment:5 Changed 6 years ago by https://id.mayfirst.org/ross

This is still super slow, I wonder if using ajax for pagination would help load the upcoming view.

comment:6 Changed 6 years ago by https://id.mayfirst.org/ross

  • Resolution set to fixed
  • Status changed from assigned to feedback

Maybe try caching the views?

comment:7 Changed 6 years ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.