Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#678 closed Bug/Something is broken (fixed)

drupal setup on mandela acting strangely

Reported by: Josue Guillen Owned by: Jamie McClelland
Priority: High Component: Tech
Keywords: validation Cc:
Sensitive: no

Description

hi all,

i just had modelpolicies.thepraxisproject.org set up as a drupal 5 site on mandela. i worked on the site all day yesterday w/o a problem. last nite, and today, i try to log in and it does not let me.

clicking inside the Username box causes the page to reload. i am able to tab my way into the box and my username and password do not work.

when i reset the password, i get the email and go to the page that resets my password. when i click on the link i get redirected to the main page.

what else did i try:

connecting to the database and replacing my password with one that i knew. still unable to log in.

created new user accounts. none allow me to log in.

a little help when you get a chance. gracias.

Change History (4)

comment:1 Changed 11 years ago by Jamie McClelland

Hi Josue - I'm also experiencing the behavior of clicking in the username or password box and having the page reload. Very strange. I am able to login, however, by going to the user page.

I would suggest narrowing down the problem by doing the following:

  • Run the home page through an html validator
  • Uninstall any third party modules
  • Revert to a default them

Somewhere there's code on the page that is causing that behavior - just not sure what code.

comment:2 Changed 11 years ago by alfredo

There's an open href tag that is defining all text between header and the login sidebar and making it hot. That's making input into the form impossible. But I couldn't find that open link tag in the source of your site nor is it visible in page.tpl.php. The question is what were you working on yesterday? Did it involve the login block at all?

The login function is working fine so it's not a drupal functional problem. The problem is that the entire box is a link. I'd follow Jamie's suggestions but first I would suggesting retracing your coding work -- something was inserted or left off there that's causing this problem and it could even be an included script or something. Keep posting as you work on it though. Maybe we can see something as you work on it.

comment:3 Changed 11 years ago by Josue Guillen

Resolution: fixed
Status: newclosed

thanks you guys. what really confused me is that i copied the page.tpl.php exactly from the toolkit.healthjustice.us site (the whole theme actually) and did not get this problem.

i was missing a closing tag for the <a href> tag in the header. it was also missing in the other site but did not have this problem. very strange, but now fixed on both.

gracias!

comment:4 Changed 11 years ago by Daniel Kahn Gillmor

Keywords: validation added
Summary: drupal setup om mandela acting strangelydrupal setup on mandela acting strangely

Jamie's recommendation of using an HTML validator is a good idea, no matter what site you're using. sites that use valid HTML (or XHTML, or whatever flavor of markup you decide) have a much better shot of rendering in a consistent fashion across different web browsers (and across different versions of the same web browser!)

A good one to start with (if you've got a public web site) is the W3C's markup validator. If you're running debian, you can also get local validators in the w3c-markup-validator and wdg-html-validator packages.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.