Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#677 closed Task/To do item (fixed)

Need two helper apps installed for Drupal module installation

Reported by: alfredo Owned by: Jamie McClelland
Priority: High Component: Tech
Keywords: Cc:
Sensitive: no

Description

I'm putting in the search attachments module for the KY Justice site. The module requires two helps apps, referended here:

http://interoperating.info/mark/search_attachments

I believe they need to be installed in a sub-dir fairly high up on the file system so I didn't want to do an installation without checking first. The problem is that while one of them, dealing with doc files, is available on debian (and not on the web, btw), the other is available on the web -- the one that deals with pdfs -- but we didn't find it in the debian distribs (using aptitude).

So, what can we do? :-)

kyjustice is going into production very soon so I'm making this a high priority item

Change History (5)

comment:1 Changed 11 years ago by Jamie McClelland

Resolution: fixed
Status: newclosed

Turns out they both are available in debian :). pdftotext is part of the xpdf-utils package and catdoc is it's own package. I just installed both packages on mandela. Both binaries are availabe in the /usr/bin/ directory:

0 jm@mandela:~$ which catdoc
/usr/bin/catdoc
0 jm@mandela:~$ which pdftotext
/usr/bin/pdftotext
0 jm@mandela:~$

comment:2 Changed 11 years ago by alfredo

This is huge. I just saw this module in actiona and it's perfect. Thanks a bunch. This is good for kyjustice but for masslaw, that has 10,000 documents to read and index, this is going to be a life-saver!

comment:3 Changed 11 years ago by alfredo

Resolution: fixed
Status: closedreopened

Ahh!!! I also need these helpers installed on malcolm where masslaw is! Sorry, forgot that and since I don't like doing unfamiliar stuff on these servers (and am quite unfamiliar with installs of packages, could you install them or tell me how to do it?

Thanks.

Re-opening this ticket.

comment:4 Changed 11 years ago by Jamie McClelland

Resolution: fixed
Status: reopenedclosed

Woops. No problem. I just installed them on mandela with:

sudo aptitude install catdoc xpdf-utils

comment:5 in reply to:  4 Changed 11 years ago by alfredo

Replying to https://id.mayfirst.org/jamie:

Woops. No problem. I just installed them on mandela with:

sudo aptitude install catdoc xpdf-utils

Just for the record, the installation you did was on malcolm. Both servers now have these helpers installed. Thanks.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.