Opened 10 years ago

Closed 6 years ago

#637 closed Bug/Something is broken (fixed)

Webmail Filter

Reported by: ana@… Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: spam webmail filter Cc:
Sensitive: no

Description

I created a Spam Assasin filter, which was working great. In the past 2 days or so, I've noticed that a lot of messages from people in my address book are being automatically deleted. I did not change anything on the filter. Just added all my contacts to the 'whitelist' but am wondering why the change and what I might do about it...

Any ideas?

I love you guys.

Ana

Change History (6)

comment:1 Changed 10 years ago by https://id.mayfirst.org/dkg

  • Keywords spam webmail filter added; Spam Webmail Filter removed

Automatically deleted? Your subject line says "webmail": Did you create the filter in horde or in squirrelmail? Were there parameters you chose during the filter setup process? Did you follow any of the recipes at filter_spam_webmail? Neither of the recipes i see there seem to automatically delete anything.

comment:2 follow-up: Changed 10 years ago by https://id.mayfirst.org/jamie

Hi Ana,

Nice to hear from you.

I see that you posted this ticket with your email address (but you won't be able to add a comment unless you login). You should be able to login with the same username/password that you use to login with the web mail.

In addition to dkg's questions - when you say deleted to you mean removed completely, or moved into your Trash folder?

Hope you're doing well.

Jamie

comment:3 in reply to: ↑ 2 Changed 10 years ago by https://id.mayfirst.org/jellobrain

Moved into my trash folder.

Replying to https://id.mayfirst.org/jamie:

Hi Ana,

Nice to hear from you.

I see that you posted this ticket with your email address (but you won't be able to add a comment unless you login). You should be able to login with the same username/password that you use to login with the web mail.

In addition to dkg's questions - when you say deleted to you mean removed completely, or moved into your Trash folder?

Hope you're doing well.

Jamie

comment:4 Changed 10 years ago by https://id.mayfirst.org/jellobrain

The spam assasin filter that I'm using has the following:

X-Spam Level - contains - * X-Spam Status - contains - Yes X-Spam Score - contains - 3

If these conditions are met, it sends stuff to the trash...

It wasn't happening before a few days ago...and I haven't really changed anything.

comment:5 Changed 10 years ago by https://id.mayfirst.org/jamie

Hi Ana,

I'm assuming you are using Horde/IMP webmail - could just confirm that?

Also - I would suggest that you change your spam filter to send messages to a spam box rather than the trash. It seems as though the problem is that your filter is being triggered when it shouldn't be triggered (as opposed to the problem being that messages are being automatically deleted). By changing your filter rule to put things in a spam box instead of the trash, we can be sure of this.

And - our spam filters are tweaked to work best when a score of 5 or more is considered spam. Your filter settings that you quote seem to have included the condition: x-Spam-Score contains 3. If you are using the horde filter setting "Any of the following" then that filter will match if the spam score is -3, 3, 33, -33, etc. Which would match a lot messages that I think you would want.

I would recommend removing your rules and adding just one: X-Spam-Flag contains YES.

If you are curious as to why good messages were transferred to your trash - you can examine the headers (by clicking the Header link above the message) and look for the fields that start with X-SPAM.

hth,

Jamie

comment:6 Changed 6 years ago by https://id.mayfirst.org/takethestreets

  • Resolution set to fixed
  • Status changed from new to closed

I'm guessing that one way or another, this has been resolved - it doesn't seem like it's the sort of thing that would go unfixed for four years. Of course, you should feel free to reopen the ticket if you have this or a similar issue.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.