Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5665 closed Bug/Something is broken (fixed)

trac-admin wiki rename failed

Reported by: https://id.mayfirst.org/ross Owned by: https://id.mayfirst.org/dkg
Priority: Medium Component: Tech
Keywords: trac support.mayfirst.org Cc:
Sensitive: no

Description

I was trying to rename a wiki title and met with this error, I wonder if it has something to do with the tagging plugin.

Trac [/srv/trac/support]> wiki rename trac-redact smo/trac-redact
AttributeError: 'TagSystem' object has no attribute 'reparent_resource_tags'
Trac [/srv/trac/support]> 

~/ross

Change History (4)

comment:1 Changed 2 years ago by https://id.mayfirst.org/ross

  • Owner set to https://id.mayfirst.org/dkg
  • Status changed from new to assigned

comment:2 Changed 2 years ago by https://id.mayfirst.org/dkg

  • Keywords support.mayfirst.org added

This appears to be due to a bug in the version of trac-tags that we're using. I'm packaging a newer svn snapshot, and will shortly move moses to it to see if that resolves the issue.

comment:3 Changed 2 years ago by https://id.mayfirst.org/dkg

  • Resolution set to fixed
  • Status changed from assigned to closed

I've upgraded trac-tags on moses to new packaging built off of upstream's revision 11105. after restarting trac-admin, the wiki rename now works fine.

Trac [/srv/trac/support]> wiki rename trac-redact smo/trac-redact
Trac [/srv/trac/support]> 

comment:4 Changed 2 years ago by https://id.mayfirst.org/dkg

I've put the new package into debian unstable as well, so that other people can get these fixes.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.