Opened 11 years ago

Closed 11 years ago

#562 closed Bug/Something is broken (fixed)

upgrade php on harry

Reported by: Jamie McClelland Owned by: Jamie McClelland
Priority: Urgent Component: Tech
Keywords: Cc:
Sensitive: no

Description

Harry is running a custom version of php because we need gmp support to get openid to work.

There have been a few php security updates since our version was installed - we should re-compile from source with the most recent security patches.

Change History (2)

comment:1 Changed 11 years ago by Jamie McClelland

I've started this process now.

I found the following notes in my home directory on harry:

To build our custom PHP debs, follow these steps (these directions assume the version is 5.2.0, replace as needed):

mkdir php5-mpfpl2
cd php5-mfpl2
apt-get source php5
cd php5-5.2.0
# edit file debian/rules
# add: --with-gmp to the COMMON_CONFIG variable
# edit file debian/changelog - add new entry at the top
screen
dpkg-buildpackage -rfakeroot -uc -b

# After the debs have been built, install the following
dpkg -i php5-common* php5_5* php5-cgi* php5-cli* php5-curl* php5-mhash* php5-mysql* php5-snmp* libapache2-mod-php5* php-pear*

comment:2 Changed 11 years ago by Jamie McClelland

Resolution: fixed
Status: newclosed

This upgrade has been completed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.