Opened 2 years ago

Closed 17 months ago

#5363 closed Question/How do I...? (worksforme)

Spamassassin update issue

Reported by: https://id.mayfirst.org/taboka Owned by: https://id.mayfirst.org/taboka
Priority: Low Component: Tech
Keywords: spamassassin Cc:
Sensitive: no

Description

You may be seeing this on other boxes, and apparently it's not just in Debian. For the last week or so, via cron results mailed to be with the title "test -x /usr/sbin/anacron
( cd / && run-parts --report /etc/cron.daily )", I'm getting:
/etc/cron.daily/spamassassin:
http: GET http://daryl.dostech.ca/sa-update/asf/1290969.tar.gz request failed: 500 Can't connect to daryl.dostech.ca:80 (connect: Connection timed out): 500 Can't connect to daryl.dostech.ca:80 (connect: Connection timed out)

I found one discussion on this (from today) at https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6761 -- but refers to https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6511 where its more fully discussed.

This doesn't seem to be too urgent, so this is mostly FYI. And maybe it will go away once the mirror is fixed.

Change History (7)

comment:1 Changed 2 years ago by https://id.mayfirst.org/ross

  • Owner set to https://id.mayfirst.org/jamie
  • Status changed from new to assigned

comment:2 Changed 2 years ago by https://id.mayfirst.org/dkg

  • Keywords spamassassin added

comment:3 Changed 2 years ago by https://id.mayfirst.org/jamie

  • Owner changed from https://id.mayfirst.org/jamie to https://id.mayfirst.org/taboka

Hi Taboka - has any progress been made with the upstream bug?

Can I assign this to you taboka? Keep us posted on the status and if there is any action we should take on our servers, please re-assign back to me. Thanks for the heads up!!

jamie

comment:4 Changed 2 years ago by https://id.mayfirst.org/taboka

I haven't seen it again since I reported it (which was about the third time I saw it). But I'll let you know if it reappears. The folks at SA Bugzilla seem to think it's low priority.

comment:5 Changed 2 years ago by https://id.mayfirst.org/dkg

It sounds to me like the problem is they are trying to fetch updates from an unreliable server. I'm not sure if there's anything that spamassassin can do about that. It tries to fetch the updates; if the server is unavailable during the time that spamassassin is trying to reach it, the update fetch will fail, and you'll see this error message.

Other than fixing the remote server (and/or fixing its network connection), what resolution are you thinking can be done from the spamassassin side?

comment:6 Changed 18 months ago by https://id.mayfirst.org/ross

  • Resolution set to worksforme
  • Status changed from assigned to feedback

I'm going to put this into feedback state. If this problem persists, please re-open this ticket.

~/ross

comment:7 Changed 17 months ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.