Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#534 closed Bug/Something is broken (fixed)

Email trouble with multiple domains

Reported by: https://id.mayfirst.org/nyma Owned by: https://id.mayfirst.org/jamie
Priority: High Component: Tech
Keywords: dns email mx Cc: anyone@…
Sensitive: no

Description

We just activated the NY Media Alliance website, but we're having trouble getting email. I think it's because of our convoluted DNS situation.

We have two websites:

nyMediaAlliance.org (and .com I think)

TheSanctuaryForIndependentMedia.org (and .com and MediaSanctuary.org)

Hits to the Sanctuary site are directed to Mayfirst; hits to nyAlliance.org go to Concison.

But email to MediaSanctuary.org is getting mapped to nyMediaAlliance and then lost--I think because the DNS for nyMediaAlliance is still controlled by Concision.

Pretty confusing. Suggestions for what to do?

Change History (7)

comment:1 Changed 11 years ago by https://id.mayfirst.org/alfredo

  • Priority changed from Medium to High

Probably the Concision doesn't have any mail records in their dns set up for you. If you're bouncing mail back from sanctuary to nymediaalliance then the provider with authority over that domain needs to do something with it and so the first thing to check is do they have records that will receive this email.

Other thing to check is why you're bouncing it back to that other domain. If you need to bounce mail back to an address, here's the way to do it:

1 -- You set up all records to send mail to us

2 -- In the email address set up in the control panel, you map an account's mail to go to whatever email address on nymediaalliance you want.

Otherwise, you'l need to get them to set up the proper records over at Concision.

Does that help at all?

Alfredo

Leaving ticket open for response. Tagging priority "high" since email delivery is involved.

comment:2 Changed 11 years ago by https://id.mayfirst.org/nyma

I'll check, but I'm not sure that's the problem. Maybe you can take a look at your end: When I go to set up email service on our Mayfirst control panel, the only account that's available is nyMediaAlliance and all of the email addresses seem to map to that domain. We want workshops@… to go to pierce@… and Andrew@… but when I send mail to that address I get a mailer daemon error:

Hi. This is the qmail-send program at smtp.taconic.net. I'm afraid I wasn't able to deliver your message to the following addresses. This is a permanent error; I've given up. Sorry it didn't work out.

<workshops@…>: 209.51.163.199 does not like recipient. ZRemote host said: 554 5.7.1 <workshops@…>: Relay access denied Giving up on 209.51.163.199.

comment:3 Changed 11 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from new to closed

Ah, I think I see what the problem is. I took these steps to figure it out:

What is the authoritative name server for nymedialliance.org?

0 jamie@liberace:~$ dig +short -t ns nymediaalliance.org
names0.concision.com.
names1.concision.com.
names2.concision.com.
names3.concision.com.
0 jamie@liberace:~$

Answer: concision.

What mail exchange is being used by nymedialliance.org?

0 jamie@liberace:~$ dig +short -t mx nymediaalliance.org
10 mail.nymediaalliance.org.
20 x1.mail.concision.com.
30 x2.mail.concision.com.
30 x3.mail.concision.com.
0 jamie@liberace:~$

A: Also concision.

What is the authoritative name server for mediasanctuary.org?

0 jamie@liberace:~$ dig +short -t ns mediasanctuary.org
b.ns.mayfirst.org.
a.ns.mayfirst.org.
0 jamie@liberace:~$

A: MFPL

What is mail exchange is used for mediasanctuary.org?

0 jamie@liberace:~$ dig +short -t mx mediasanctuary.org
0 jamie@liberace:~$

A: Not set!

I just set it now by going to the DNS service in your Members Control Panel and creating a record of type "MX". When the mail exchange is not set in our system - it won't provide a drop down for you in the email address section of the control panel.

It may take a few hours for this change to propagate throughout the Internet.

Please re-open the ticket if the problem persists. Thanks!

Jamie

comment:4 Changed 11 years ago by https://id.mayfirst.org/nyma

Thanks! We now have workshops@… working but there are still a few issues...

We have two aliases for www.MediaSanctuary.org:

www.TheSanctuaryforIndependentMedia.org and .com

Email sent to those domains is still bouncing.

Also, is there a way to make email sent to [anything]@MediaSanctuary.org come to a default address, such as info@…?

comment:5 Changed 11 years ago by https://id.mayfirst.org/jamie

I just added "mx" records for those two domains, so they should show up in the drop down list now.

You can do an [anything]@ style email address (just leave the first part empty when creating the address). However, I caution against it - it will become a huge spam trap.

comment:6 Changed 11 years ago by https://id.mayfirst.org/dkg

  • Keywords dns email mx added
  • Summary changed from Email trubble to Email trouble with multiple domains

I agree with Jamie about avoiding ![anything]@-style addresses: don't do it!

If you have not explicitly published an e-mail address, there is little sense in spending your time sifting through all of the mail that will eventually come in for it. Better to leave it undefined, and let misaddressed mail be properly rejected. That saves time for you (less struggling with spam), for the sender (they should get immediate alerts from their SMTP provider that their misaddressed e-mail was rejected), and for the servers involved (less processing of junk mail is more compute time that can be spent processing real mail).

comment:7 Changed 11 years ago by https://id.mayfirst.org/nyma

OK--I'll take your advice on this! And thanks for the help working through the email problems...

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.