Opened 7 years ago

Closed 7 years ago

#4866 closed Bug/Something is broken (fixed)

problem with permissions - can't upload anything to eagle server

Reported by: https://id.mayfirst.org/quixote Owned by: https://id.mayfirst.org/ross
Priority: High Component: Tech
Keywords: file-permissions Cc:
Sensitive: no

Description

hi - I'm trying to upload Wordpress to the eagle server (quixote.org) which I was able to access it via FTP. But the upload is failing, saying that my user account doesn't have the proper permissions. I created a new user but still no go.

specifically it says "SSH Error: Cannot create folder wordpress" and then "Permission denied (SSH_FX_PERMISSION_DENIED: The user does not have sufficient permissions to perform the operation."

I tried to change the permissions but it won't let me (using cyberduck btw). I think it has something to do with the Drupal install but I'm not sure what to do because it won't let me delete any of the files either.

let me know soon - we're trying to get a new site up there asap. thanks, burke

Change History (8)

comment:1 Changed 7 years ago by https://id.mayfirst.org/ross

  • Owner set to https://id.mayfirst.org/ross
  • Status changed from new to assigned

Hi burke,

This could depend on what user account you're using to login. Looking at the permissions on the files, it looks like you should be using quixote as the user for uploading files. Is this the username you were using? If not, could you try that user and see if it fixes the problem?

thanks,

~/ross

comment:2 Changed 7 years ago by https://id.mayfirst.org/quixote

yup, I was using quixote. I tried another user too but that's the main one I've been logging in with.

comment:3 Changed 7 years ago by https://id.mayfirst.org/ross

  • Keywords file-permissions added

Okay, looking at the site I see no reason why quixote user couldn't upload files. Are you sure you're attempting to upload them into the web directory? The full path would be

/home/members/quixote/sites/quixote.org/users/quixote/quixote.org/web/

Can you check to make sure that's the directory you're attempting to use?

thanks,

~/ross

comment:4 Changed 7 years ago by https://id.mayfirst.org/quixote

yup, that's the folder - just tried it again and it failed with the same error message as before. I've also tried uploading to various other directories just to test and it also fails.

comment:5 Changed 7 years ago by https://id.mayfirst.org/ross

hi burke,

I just created a directory at web/wordpress and set the permissions so that anyone can write to that directory...Can you try that and see if you can upload to it?

~/ross

comment:6 Changed 7 years ago by https://id.mayfirst.org/quixote

that worked - thanks! at some point we'll want to drop the contents of that directory into the "web" directory... so we'll still need to change the permissions of that folder as well. thanks again. -burke

comment:7 Changed 7 years ago by https://id.mayfirst.org/ross

  • Resolution set to fixed
  • Status changed from assigned to feedback

Hi burke,

I think I made the appropriate changes to the web directory. All should be fixed now.

~/ross

comment:8 Changed 7 years ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.