Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#470 closed Bug/Something is broken (fixed)

Mailing list bounces and non-delivery

Reported by: martin.thomas@… Owned by: https://id.mayfirst.org/jamie
Priority: Urgent Component: Tech
Keywords: bouncing email mailman Cc: martin.thomas@…
Sensitive: no

Description

Hi,

I've also left phone messages about this, because I thought that not being able to log in would also stop me posting a ticket. However, turns out I can post a ticket.

Our website is www.workersliberty.org/ workersliberty.mayfirst.org

(1) Email sent to our e-lists (....@…) is bouncing.

(2) Email sent to email addresses hosted on your server (...@…) is bouncing.

I'm sorry, I don't have samples of the bounced emails. I've been notified of these problems by someone else. I've asked him to send me a copy of the bounce message, but it hasn't arrived. I've sent some test messages to myself and to lists I'm on, but received no response (neither an error message, nor a normal delivery of the messages).

Presumably you won't be able to contact me on my normal e-address martin@workersliberty, but martin.thomas@… will reach me. Other email on that address is arriving normally. Or you can phone me at +44 20 7207 3997.

(3) I can't log in on your website. The website just returns the message "wrong password".

Hope you can help,

Thanks,

Martin Thomas

Change History (8)

comment:1 Changed 11 years ago by https://id.mayfirst.org/jamie

I'm working on this now Martin - posting the bounce error will be really helpful.

In the course of working on this problem - I discovered another problem (I opened ticket #475 to track that problem).

comment:2 in reply to: ↑ description Changed 11 years ago by https://id.mayfirst.org/jamie

  • Keywords email added

(1) Email sent to our e-lists (....@…) is bouncing.

It looks like you have a dozen or so lists. Can you specify the name of the list (without the email address part)? That way I can try to identify any bounce messages in our logs.

(2) Email sent to email addresses hosted on your server (...@…) is bouncing.

I've just looked through our logs for your email address and am not seeing any bounce messages - but I am seeing a lot of successful deliveries. If you can post a sample bounce message it would be great.

I'm sorry, I don't have samples of the bounced emails. I've been notified of these problems by someone else. I've asked him to send me a copy of the bounce message, but it hasn't arrived. I've sent some test messages to myself and to lists I'm on, but received no response (neither an error message, nor a normal delivery of the messages).

What email address did you sent it from? And which email address did you sent it to? Our ticket system will obscure the email address if you type it as a normal email address - so please post in the form: user [at] domain [dot] org.

(3) I can't log in on your website. The website just returns the message "wrong password".

Which web site are you trying to login to? Your drupal site? Or our web site? Please post the web address.

comment:3 Changed 11 years ago by https://id.mayfirst.org/jamie

Just now see that you've posted #471 and #472. I'm marking them as duplicates of this one (and keeping this one open to track). Please click the login link at the top of this page. Then you will be able to post comments to tickets (rather than opening new ones).

If the web site you can't login to (that you reference above) is this web site - then post a new ticket letting us know :).

comment:4 Changed 11 years ago by https://id.mayfirst.org/jamie

The error message in #472 was also reported by Jon (in ticket #456). The problem is: sending email from our new webmail server to another address produces bounces. I just updated #456 and hopefully fixed it.

comment:5 Changed 11 years ago by https://id.mayfirst.org/jamie

I think I tracked down the problem you had (referenced in #471) about sending to your awl-external list and not getting any response or bounce.

Please check your sender filter rules:

https://lists.mayfirst.org/cgi-bin/mailman/admin/awl-external/privacy/sender

You have configured your list so that the action to take when a moderated list members posts (and the action to take when a non-moderated list member posts) is to discard the message. You are a moderated list member, so our mailman software did it's job and discarded your message.

You probably want to change that behavior to hold moderated members' postings for approval instead.

comment:6 Changed 11 years ago by https://id.mayfirst.org/workersliberty

Hi Jamie,

Yes, all seems to be working fine again now, other than Sacha's problem with downloading a particular message from his webmail which he says he has a reply on.

I'm puzzled by the awl-external thing, because I was sure I'd set myself not to be moderated (i.e. to do the announcing on this, which is an announcements list). But my mistake, obviously.

The log-in seems to work again. Very mysterious, but whatever the problem was, it's fixed.

Thanks again.

comment:7 Changed 11 years ago by https://id.mayfirst.org/workersliberty

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 11 years ago by https://id.mayfirst.org/dkg

  • Keywords mailman added
  • Summary changed from (1) E-lists bouncing messages; (2) Email addresses hosted on your site bouncing messages; (3) not able to log in to Mailing list bounces and non-delivery

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.