Opened 7 years ago

Last modified 7 weeks ago

#4498 assigned Question/How do I...?

Wordpress & FTP

Reported by: https://id.mayfirst.org/rooster Owned by: https://id.mayfirst.org/jaimev
Priority: Urgent Component: Tech
Keywords: wordpress, ftp Cc:
Sensitive: no

Description

Hello,

I'm trying to do 2 things that I hope someone in support can help me out with.

  1. Casa would like to use wordpress for the home page so it's easy to update via mobile devices. Whats the best way to go about doing this?
  1. We would like to upload pages via an FTP client and wanted to know the ftp addy to do so? Is it ftp.casaatabexache.org with the same admin login?

Thanks in advance

Change History (7)

comment:1 Changed 7 years ago by https://id.mayfirst.org/ross

  • Keywords wordpress ftp added
  • Owner changed from https://id.mayfirst.org/jamie to https://id.mayfirst.org/ross

Hi rooster,

In order to ftp into your site you need to find your primary server, you can do this by logging into the member's control panel @ https://members.mayfirst.org/cp . It looks like your server is viewsic.mayfirst.org. The server would be the ftp host. For more info check the faq:

https://support.mayfirst.org/wiki/sftp

As far as using a mobile device to update a wordpress site, I can't offer much help there. Depending on the device, it should be possible to update any wordpress site using a mobile device. However, I'm not sure how easy it would be to do such updates. If you need help installing wordpress, you can check out this faq:

https://support.mayfirst.org/wiki/WordPressInstall

hope this helps,

ross

comment:2 Changed 7 years ago by https://id.mayfirst.org/ross

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 2 months ago by https://id.mayfirst.org/devinvnetwork

Hi. Trying to set up WordPress core updates at a website /wp-admin/update-core.php?action=do-plugin-upgrade

I keep getting the error "Failed to connect to FTP Server www.erica.mayfirst.org:21"

I'm using the same FTP Server, Username and Password as I'd use in Filezilla but it isn't working. Any ideas for what I'm doing wrong? Thanks.

comment:4 Changed 8 weeks ago by https://id.mayfirst.org/devinvnetwork

Please help. :)

comment:5 Changed 7 weeks ago by https://id.mayfirst.org/jaimev

  • Resolution fixed deleted
  • Status changed from closed to assigned

Hi, you should be using sftp to connect to your server however it also shouldn't be necessary to provide ftp credentials in order for the site to update itself. If you remove the ftp option entirely are you able to run updates?

comment:6 Changed 7 weeks ago by https://id.mayfirst.org/devinvnetwork

I am using sFTP.

Everything I've found online suggests that you need to add FTP credentials to use the automatic update and automatic plugin install features of WordPress.

ex. https://stackoverflow.com/questions/640409/can-i-install-update-wordpress-plugins-without-providing-ftp-access

I don't know what "remove the ftp option entirely" could mean. Can you explain?

comment:7 Changed 7 weeks ago by https://id.mayfirst.org/jaimev

  • Owner changed from https://id.mayfirst.org/ross to https://id.mayfirst.org/jaimev

So I know its stupid and confusing but ftps is actually not the same as sftp

http://www.differencebetween.net/technology/internet/difference-between-ftps-and-sftp/

If you access your account over ssh we have installed a command line utility wp-cli that allows for some basic maintenance without accessing the web admin interface. I am using it in the below example to see how the ftp_credentials is set in the database.

0 vnetwork@erica:~/g0v.network/web$ wp option get ftp_credentials
array (
  'hostname' => 'erica.mayfirst.org',
  'username' => 'devinvnetwork',
  'connection_type' => 'ftps',
)

I am removing that option completely as per my suggestion.

0 vnetwork@erica:~/g0v.network/web$ wp option delete ftp_credentials
Success: Deleted 'ftp_credentials' option.

Core updates should still work because all files should be owned and excecuted by the same user, so wordpess doesn't need to establish a separate ftp connection to write to files. You can see which user is assigned to own files and processes in your web configuration tab of the control panel, which is vnetwork. However in this case it seems that you uploaded the wordpress files as devinvnetwork. This makes the files owned by devinvnetwork instead of vnetwork and wordpress can't write to them, this is likely the root cause of your upgrade woes.

I'm gone ahead and fixed ownership of the files now. In the future you'll want to connect as the vnetwork to do any file maintenance.

Below I'm just trying to apply the core upgrade but it seems that this site is already up to date. You should be able to do the same through the web interface and updates themes and plugins that way too.

0 vnetwork@erica:~/g0v.network/web$ wp core update
Success: WordPress is up to date.
0 vnetwork@erica:~/g0v.network/web$ wp core update-db
Success: WordPress database already at latest db version 38590.
0 vnetwork@erica:~/g0v.network/web$ wp core check-update
Success: WordPress is at the latest version.
0 vnetwork@erica:~/g0v.network/web$ wp core version
4.9.6

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.