Opened 11 years ago

Closed 6 years ago

#433 closed Bug/Something is broken (fixed)

Deleting users does not delete webmail settings

Reported by: https://id.mayfirst.org/jamie Owned by: https://id.mayfirst.org/jamie
Priority: High Component: Tech
Keywords: webmail email red Cc:
Sensitive: no

Description

I'm opening this ticket in response to ticket #430.

Consider this scenario:

  • User account sally is created.
  • Email address sally@… is created
  • User sally logs into webmail and sets her preferences.
  • These preferences are recorded in the webmail database and tagged to the user account sally.
  • The user account sally is deleted - which deletes the user account and the email address and email messages, however, this process doesn't touch the webmail database.
  • A new user account sally is created
  • Email address sally@… is created
  • The user logs into webmail and the old sally preferences pop up because the preferences were never deleted (and the preferences are tagged to the username, not the email address, so even if the new sally has a different email address she will still see the old preferences)

The email messages will not show up (so we don't have an egregious privacy situation here) - however, things like the address book entries will show up (which does have serious privacy implications).

I think the solution is to figure out a way to clear webmail settings when a user account is deleted.

Change History (4)

comment:1 Changed 11 years ago by https://id.mayfirst.org/jamie

  • Keywords webmail email red added
  • Priority changed from Medium to High

comment:2 Changed 10 years ago by https://id.mayfirst.org/schr

I am not sure if this is related. I just created a bunch of users in my red, and then deleted them thinking I had created them in the wrong place. When I try to create them again, it tells me that I am using a username that has been taken. Is there a way to either restore the users that I created before, or erase the memory of those old users that I deleted so that I can re-enter them?

comment:3 Changed 10 years ago by https://id.mayfirst.org/jamie

I think you are experiencing a different ticket Ana (this one is specific to webmail). I just created a new ticket (#1300) and will follow up there.

comment:4 Changed 6 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from new to closed

Superseded and closed in #1532

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.