Opened 11 years ago

Closed 11 years ago

#411 closed Bug/Something is broken (fixed)

why didn't i get this email?

Reported by: https://id.mayfirst.org/helenajf Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: email Cc:
Sensitive: no

Description

hi,

was cc'd on the following email. Dara@… received it, but I never did. you know why?

Subject: Re: Tomorrow's Fundraising committee meeting Date: Wed, 9 Jan 2008 23:39:51 -0500 From: Jenny Levison <jenny@…>

Change History (4)

comment:1 in reply to: ↑ description Changed 11 years ago by https://id.mayfirst.org/dkg

  • Keywords email added

Just making the details more readable:

Subject:  	Re: Tomorrow's Fundraising committee meeting
Date: 	Wed, 9 Jan 2008 23:39:51 -0500
From: 	Jenny Levison <jenny@dotellproductions.com>

comment:2 Changed 11 years ago by https://id.mayfirst.org/jamie

Thank you for the report Helena!

This is very useful to us - you seem to have found a bug in the software we use for greylisting (see our greylisting faq for more information. I just opened a new ticket to discuss the technical details. Feel free to cc: yourself on it if you want to follow along.

It's a rather unusual situation, so I wouldn't expect it to happen again - but it's certainly something we will be working on fixing.

comment:3 Changed 11 years ago by https://id.mayfirst.org/jamie

I just updated ticket #413 (where we are discussing the technical details). It turns out that this is not a bug with our system after all. Our servers are acting properly. It does appear to be a bug with the sending server (the dotellproductions.com sending mail server). I've just added an exception to our server's configuration for them - so this problem should not happen in the future. I've also sent their mail administrators an email alerting them to the fact that their mail servers are not functioning properly.

comment:4 Changed 11 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from new to closed

The email to the mail administrators bounced :(.

I also modified our white list to allow any of the various servers used by dotellproductions.com to send email after Helena called to report that the problem happened again.

Technical details: I had added mtao03.charter.net to /etc/postgrey/whitelist_client.local. I checked the mail logs and realized the the same email address was sending email from mtai03.charter.net, so I changed the entry in /etc/postgrey/whitelist_client to /.*\.charter\.net/ (which should match against any .charter.net server).

I think this should close the ticket - but if you get a repeat Helena please re-open. Thanks!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.