Opened 11 years ago

Closed 7 years ago

#398 closed Feature/Enhancement Request (duplicate)

Internationalization of our trac installation

Reported by: Jamie McClelland Owned by: Jamie McClelland
Priority: High Component: Tech
Keywords: trac internationalization Cc:
Sensitive: no

Description

I think it's important for us to provide the trac user interface in spanish (and, at this time less importantly, in other languages as well). We now have a member (developing their site at http://wdrc.mayfirst.org/) that is more comfortable in spanish than english and we may have many more in the future.

It looks like a spanish translation began with trac version .10 but has ceased development because of a project called babel that is being developed by the edgewall people.

I'm not sure the best direction (or how close either of these solutions are to being usable) but wanted to start this discussion.

Change History (5)

comment:1 Changed 11 years ago by alfredo

Looks like what they've done up to now is translate the basic link terms into Spanish which would mean us going in, making the changes (which we could do without what they've done since they're only translations) and then publishing the alternative navigation.

I'm assuming we'd want the person to push a button to go to Spanish but that the same tickets would be visible in their original language but I don't know trac enough to know how it's structured and how one would do that.

Nothing that I know of can translate tickets from one language to another reliably. So a truly bi-lingual system would require tranlation of each post by someone here: a prohibitively time-consuming task.

But if we could at least do a Spanish navigation that can be toggled with English on the same system, it would be a huge step forward -- at least as an expression of political intent if not a real translated content offering.

comment:2 Changed 11 years ago by Jamie McClelland

Yes - I agree. I'd like to see the user interface translated - preferably in a clean, system-wide way so that trac detects the user's language by their browser settings and automatically switches to the spanish (or any other language). Seems like this idea is underway.

As for the contents of tickets - I also think that we should not be trying to automatically translate them. If we start getting a lot of Spanish language tickets - we may want to add a field to the ticket for language so people can filter tickets by their own language. I don't think we'll be running into this problem soon though.

comment:3 Changed 8 years ago by Jamie McClelland

Seems like there is some new movement in trac on this issue.

jamie

comment:4 Changed 7 years ago by Joseph

Keywords: trac internationalization added
Priority: MediumHigh
Status: newassigned

comment:5 Changed 7 years ago by Daniel Kahn Gillmor

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #4952, which is resolved!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.