Opened 11 years ago

Closed 11 years ago

#384 closed Feature/Enhancement Request (fixed)

Drupal 5.x installation for fairvotemn.org

Reported by: FairVote MN Owned by: Jamie McClelland
Priority: Low Component: Tech
Keywords: drupal Cc:
Sensitive: no

Description

Howdy MF,

I'd like to request a Drupal 5.x installation for fairvotemn.org so I can begin working on upgrading their codebase and migrating data.

Thanks, Jesse Mortenson

IDC WebDev 651-442-5734

Change History (10)

comment:1 Changed 11 years ago by Daniel Kahn Gillmor

Keywords: drupal added
Summary: Drupal 5.x upgradeDrupal 5.x installation for fairvotemn.org

comment:2 Changed 11 years ago by Jamie McClelland

Resolution: fixed
Status: newclosed

Hi Jesse,

Since you are hosted on viewsic, your drupal setup is a little different then on our other shared hosting servers.

I saw that you still had a hosting order called drupal47 to manage your upgrade from Drupal 4.6 to Drupal 4.7. I backed it up (just in case) and then removed it. Then, I created a hosting order called dev.fairvotemn.org. With the more generic name, we can keep it around so you can use it for future upgrades or development work.

This new hosting order is configured to use Drupal 5. I re-created your short cut in your fairvote home directory (fairvote_drupal5) which points to your "sites" directory - where you can put your modules and themes directories.

Once you are happy with dev.fairvotemn.org, you can go into the Members Control panel and change the web configuration for the regular fairvotemn.org site to use /usr/local/share/drupal-5 instead of /usr/local/share/drupal-4.7.

I'm going to close this ticket - if you run into any problems please don't hesitate to re-open it.

comment:3 Changed 11 years ago by FairVote MN

Resolution: fixed
Status: closedreopened

Howdy again. I'm having the same problem that I ran into when I upgraded this to 4.7 (recap below): I can't access dev.fairvotemn.org/update.php. Except this time I can't seem to get my "edit cookies.txt" workaround to work. Drupal is not authenticating my browser as being the logged-in UID 1 user (most likely) because the cookie for www.fairvotemn.org does not qualify for dev.fairvotemn.org.

I think the problem is that, according to the Drupal upgrade steps, the test site (in this case dev.fairvotemn.org) would have been started out with the existing (4.7) codebase. That would allow me to ensure I was logged in at that subdomain as UID 1, then change codebase, then run update.php. In this case the test site starts out as the new codebase, so I can't re-login at the new subdomain.

Ideas? Am I missing part of the process that usually works for you?

Thanks, Jesse

comment:4 Changed 11 years ago by alfredo

Hi Jesse,

I don't see an update.php file in that drupal 5 directory. Since I haven't been following this situation, I may be wrong here but calling the update script is going to fail if its path isn't found. What error are you getting exactly?

Alfredo

comment:5 Changed 11 years ago by FairVote MN

If you visit http://dev.fairvotemn.org/update.php you should see the error. The update.php file should be part of the shared drupal codebase. On a non-shared (or non-access-restricted) installation I could just edit update.php to turn the access check off temporarily.

comment:6 Changed 11 years ago by Jamie McClelland

Hi Jesse - I just added a new ticket to address the underlying problem.

I'm going to switch your account to the symlink approach. Then - you can modify your own update.php file and enable your permissions. I'll post when I've completed it.

comment:7 Changed 11 years ago by Jamie McClelland

Ok - I just made the switch. Now - your dev site is just reporting the number "2" - I'm not sure if this is due to testing that you have been doing (or whether I did something wrong!). Please post to this ticket if I inadvertently created a new problem.

I also changed the fairvote_drupal5 symlink so that instead of pointing to your site directory in the shared sites directory, it points to your new full web tree. You will see that now you have what appears to be your own Drupal installation in your web directory. However, rather than the actual Drupal files, they are symlinks to the central Drupal code.

So - if you want to make a modification to your update.php file to temporarily edit the permission setting, you can do it by:

  • Move (rename) the file called update.php to update.php.bak
  • Copy the file /usr/local/share/drupal-5/update.php to your web directory
  • Edit that file to enable access
  • When you are done, remove that file and move (rename) update.php.bak to update.php

This is a pretty big move - so I will leave the ticket open. Please close it if it works (or post a follow up if it doesn't work). Thanks

comment:8 Changed 11 years ago by FairVote MN

Resolution: fixed
Status: reopenedclosed

This method seems to have worked pretty well. You forgot to copy over .htaccess, but that was easily remedied. I have most of the work done (http://dev.fairvotemn.org), though it's not done yet.

Incidentally I started using this shared codebase method (symlinks vs. the sites/ directory) on my company's server after I encountered you guys using it for the AllSaintPaul project's installation. It's good.

comment:9 Changed 11 years ago by FairVote MN

Priority: LowMedium
Resolution: fixed
Status: closedreopened

I tried making the switchover tonight, but I'm hung up on the web configuration settings in the member control panel. I tried some different settings, but I keep getting an apache 500 Internal Server Error after making the change. Here's what I was trying:

ServerName fairvotemn.org
ServerAlias www.fairvotemn.org fairvote.mayfirst.org city.betterballotcampaign.org city.fairvote.mayfirst.org betterballotcampaign.org www.betterballotcampaign.org stpaul.betterballotcampaign.org saintpaul.betterballotcampaign.org mpls.betterballotcampaign.org betterballotcampaign.fairvote.mayfirst.org survey.fairvotemn.org
DocumentRoot /home/members/fairvote/sites/dev.fairvotemn.org/web
CustomLog /home/members/fairvote/sites/fairvotemn.org/logs/web.log combined
ScriptAlias /cgi-bin home/members/fairvote/sites/dev.fairvotemn.org/cgi-bin
# Added by jamie 2007-10-22 after server upgrade removed index.htm from the list of default index
# file names and a search indicated that there was at least one file named index.htm in this
# members web directory
DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm

I also tried adding "php_admin_value open_basedir none" and "Options FollowSymLinks" but those didn't help.

What am I missing/doing wrong? I'm guessing that I have the system path wrong, but I'm not sure what else it should be under the symlink setup.

comment:10 Changed 11 years ago by FairVote MN

Priority: MediumLow
Resolution: fixed
Status: reopenedclosed

Update: found a pointer over here https://support.mayfirst.org/ticket/704 which led me to the AllowOverride solution (ie, .htaccess was the problem). Good work with the trac ticket system, helped me find my own solution.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.