Opened 10 years ago

Closed 10 years ago

#379 closed Bug/Something is broken (fixed)

can't login into my email

Reported by: https://id.mayfirst.org/chrisjx Owned by: https://id.mayfirst.org/jamie
Priority: Urgent Component: Tech
Keywords: email Cc:
Sensitive: no

Description

I have made several attempts to login to my email in safari and firefox both browsers give me this message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, apache@… and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log. Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c Server at malcolm.mayfirst.org Port 80

Change History (17)

comment:1 Changed 10 years ago by https://id.mayfirst.org/jamie

  • Keywords email added
  • Type changed from Question/How do I...? to Bug/Something is broken

Thanks for the report Chris. I just tested myself and didn't get an error. Can you post the exact URL (web address) you were visiting when you got the error? Also - did you get the error immediately when you visit the address, or after entering your username and password? Thanks.

comment:2 follow-up: Changed 10 years ago by https://id.mayfirst.org/chrisjx

this is the url where I have been logging in:

http://malcolm.mayfirst.org/horde3/imp/login.php

I enter in my login data, and it gives me the error message after ~5 minutes

comment:3 in reply to: ↑ 2 Changed 10 years ago by https://id.mayfirst.org/chrisjx

Replying to https://id.mayfirst.org/chrisjx:

http://malcolm.mayfirst.org/horde3/imp/login.php -> It worked this morning

I now have access to my email!!

Thanks support @ Mayfirst

Chris @ JungleX

comment:4 Changed 10 years ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from new to closed

Closing the ticket because the problem is resolved. Thanks Chris for the report back.

I'm still not sure what the problem was but I notice that the original error message was using SSL/encryption (in other words https) whereas it seems like Chris, you are now using a non-encrypted connection (http).

I think we should require people to use encryption - I would open a new ticket to do that - but I'm hoping we'll be switching to a new webmail system very shortly (see ticket #170) which is already configured to do that.

comment:5 Changed 10 years ago by https://id.mayfirst.org/chrisjx

  • Priority changed from Medium to Urgent
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 10 years ago by https://id.mayfirst.org/chrisjx

okay...I followed some tickets as suggested and logged in via this link:

https://webmail.dev.mayfirst.org/

should I be using this from now on?

comment:7 follow-up: Changed 10 years ago by https://id.mayfirst.org/jamie

Hi Chris - I would advise against using the address. The site is still under development - so if you save items in your address book or make any configuration changes, they may be lost when we go live.

Unfortunately, I still can't replicate the error you are having with https://malcolm.mayfirst.org/horde3. Can you tell us what IP address you are connecting with? If you are not sure, you can check at this address: http://ip.mayfirst.org.

Thanks - with that information I can more reliably search our error logs to find the cause of the problem.

comment:8 in reply to: ↑ 7 Changed 10 years ago by https://id.mayfirst.org/chrisjx

Replying to https://id.mayfirst.org/jamie:

Hello Jamie,

my ip address: 24.37.48.138

https://malcolm.mayfirst.org/horde3

worked yesterday not today though...

I appreciate your efforts!

Thanks

Chris

comment:9 Changed 10 years ago by https://id.mayfirst.org/jamie

Thanks Chris - I appreciate your patience!

I found the error in our logs:

[Mon Jan 07 11:31:16 2008] [error] [client 24.37.48.138] Premature end of script headers: redirect.php, referer: http://malcolm.mayfirst.org/horde3/imp/login.php

Given that I'm seeing very high loads on Malcolm (the server that is providing this service), my guess is that means that our web server is timing out during the redirect. That would also explain why it happens sometimes but not others.

This is a pretty big problem - I'll be working hard to get the new webmail server up and running which should solve the problem. In the meantime, if you get the error again, please feel free to use https://webmail.dev.mayfirst.org - however please do not change your settings or use your address book. I'm hoping by early next week we will launch that site (at which point you can use those features).

comment:10 Changed 10 years ago by https://id.mayfirst.org/chrisjx

Starting Feb 21 2008, I have attempted to login
via 3 different locations and using various urls
such as :

https://members.mayfirst.org/

https://members.dev.mayfirst.org/

https://webmail.dev.mayfirst.org/

...without success!

I have had trouble logging in for many weeks now.

Sometimes it's the 20th attempt that works, so I
keep patiently waiting for the fix to set in.

But the next day it's the same thing.

I need a solution asap!'''

I apprecate your efforts

comment:11 Changed 10 years ago by https://id.mayfirst.org/jamie

Hi Chris -

https://members.mayfirst.org/

Is the proper address to use. When you say "without success" do you mean that you get a login incorrect error message - or are you able to login, but you do not see your messages?

Jamie

comment:12 Changed 10 years ago by https://id.mayfirst.org/chrisjx

"without success"
meaning after after I hit the login button
there is 5 mins of waiting, then I get the
white page error message

comment:13 Changed 10 years ago by https://id.mayfirst.org/chrisjx

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, apache@… and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log. Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c Server at webmail.mayfirst.org Port 443

comment:14 Changed 10 years ago by https://id.mayfirst.org/jamie

Thanks Chris - is this happening with any of your other users? We haven't received a report like this from anyone else - so I am wondering if there is something we need to fix related to your username. I'm about to leave for a workshop - but can follow up this weekend.

In the meantime, can you try logging in via squirrelmail:

https://webmail.mayfirst.org/squirrelmail/src/login.php

Thanks for your patience!

comment:15 Changed 10 years ago by https://id.mayfirst.org/chrisjx

https://webmail.mayfirst.org/squirrelmail/src/login.php

logged me into my email in seconds but I have no access to my folders.

thanks jamie

comment:16 Changed 10 years ago by https://id.mayfirst.org/chrisjx

oh wow, i just found folder access in squirrel

comment:17 Changed 10 years ago by https://id.mayfirst.org/alfredo

  • Resolution set to fixed
  • Status changed from reopened to closed

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.