Opened 9 years ago

Last modified 6 years ago

#3074 assigned Bug/Something is broken

javascript error on http://mayfirst.org/ under konqueror

Reported by: https://id.mayfirst.org/dkg Owned by: https://id.mayfirst.org/jamie
Priority: Low Component: Tech
Keywords: javascript mayfirst.org Cc:
Sensitive: no

Description

When i visit http://mayfirst.org/blogs with konqueror, i get an error dialog that says:

An error occurred while attempting to run a script on this page.

http://mayfirst.org/blogs line 361:
ReferenceError: Can't find variable: border
[ ] Do not show this message again
         [Debug] [OK]

I assume there is a scripting error on the page. i will attach a screenshot of the error dialog.

Attachments (2)

blogs-script-error.png (21.5 KB) - added by https://id.mayfirst.org/dkg 9 years ago.
error.png (11.5 KB) - added by https://id.mayfirst.org/dkg 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by https://id.mayfirst.org/dkg

comment:1 Changed 9 years ago by https://id.mayfirst.org/dkg

comment:2 Changed 9 years ago by https://id.mayfirst.org/jamie

Thanks dkg. I just commented it out without any noticeable ill effects. Looks like it was intended to round the tab borders, but not sure. Alfredo - do you have a recollection about why that code is in there?

jamie

comment:3 Changed 6 years ago by https://id.mayfirst.org/ross

  • Keywords mayfirst.org added; http://mayfirst.org removed
  • Resolution set to fixed
  • Status changed from new to closed

I doubt this is still an issue.

comment:4 Changed 6 years ago by https://id.mayfirst.org/dkg

  • Resolution fixed deleted
  • Status changed from closed to assigned
  • Summary changed from javascript error on http://mayfirst.org/blogs under konqueror to javascript error on http://mayfirst.org/ under konqueror

This is indeed still a problem, though the error has changed over the years. Now it's an error even on the main page. Did you test it?

sudo apt-get install konqueror
konqueror https://mayfirst.org/

The current error is:

An error occurred while attempting to run a script on this page.
http://mayfirst.org/sites/default/files/js/js_2102bfef8dbaddd8a8c880465401c3... line 459: TypeError: Null value
[ ] Do not show this message again
                                    [OK] [Debug]

Looking at the line of code in question, it appears to be that the "match" statement here returns a Null result, which is then subscripted with [1]:

   $.browser.version = navigator.userAgent.toLowerCase().match(/.+(?:rv|it|ra|ie)[\/: ]([\d.]+)/)[1];
Last edited 6 years ago by https://id.mayfirst.org/dkg (previous) (diff)

Changed 6 years ago by https://id.mayfirst.org/dkg

comment:5 Changed 6 years ago by https://id.mayfirst.org/jamie

  • Priority changed from Medium to Low

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.