Opened 9 years ago

Closed 5 years ago

#2453 closed Bug/Something is broken (fixed)

Issue with one email address

Reported by: https://id.mayfirst.org/praxis_web Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: email Cc:
Sensitive: no

Description

I'm having an issue with one email address, and one email address only, on my domain. The address is ycadore@….

On this user's machine, she is able to log in using webmail. On Thunderbird, her account settings are:

username: ycadore password: [not going to reveal] incoming server: viewsic.mayfirst.org (SSL, Port 993) smtp server: viewsic.mayfirst.org (TLS, Port 25)

This account times out when Thunderbird tries to connect. I've tried creating the account in Outlook, and get unspecified failures when I try to test settings. The same things happen on other machines, too. Her machine is Vista - I've tried testing on XP, Mac OS X and Ubuntu.

Please advise.

Change History (8)

comment:1 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi,

The only problem I see with the setting is that the smtp port should be 587 - but that should only cause a time out when sending email, not receiving it.

I'm also seeing what appears to be a successful POP login:

Sep  3 16:12:23 viewsic pop3d-ssl: LOGIN, user=ycadore, ip=[::ffff:71.166.161.165]
Sep  3 16:12:56 viewsic pop3d-ssl: LOGOUT, user=ycadore, ip=[::ffff:71.166.161.165], top=0, retr=0, rcvd=12, sent=49, time=33

Are you coming from the IP 71.166.161.165?

jamie

comment:2 Changed 9 years ago by https://id.mayfirst.org/praxis_web

Jamie, I'll check that out in re: port 587. It's odd that you're seeing a POP login, as I never once configured it as POP, always IMAP.

I can't for the life of me imagine why this is happening. Perhaps the solution is to move her stored email to a dummy account, and then kill and recreate the account?

I'm as puzzled as you are.

Dheeraj

comment:3 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi Dheeraj,

The only other thing I could think of is a firewall issue. However, I assume you are able to establish connections to viewsic using other usernames.

Just to be sure - you could try:

 telnet viewsic.mayfirst.org 993

From the machine that is timing out when it tries to connect

You should get something like this:

0 jamie@liberace:~$ telnet viewsic.mayfirst.org 993
Trying 209.51.172.6...
Connected to viewsic.mayfirst.org.
Escape character is '^]'.
^C^C
Connection closed by foreign host.
1 jamie@liberace:~$

jamie

comment:4 Changed 9 years ago by https://id.mayfirst.org/praxis_web

Jamie,

Thanks so much for your continued aid on this. The problem is bewildering to me, to say the least. Unfortunately, the machine is no longer in my possession. It is a laptop that one of our staff members uses to work remotely. She just happened to bein town yesterday, which is how I found out about it. She's quite gone, now, though, and not very comfortable in Vista alone, much less, at the command line.

Can we try to figure something else out? Sorry to be so difficult.

Dheeraj

comment:5 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi Dheeraj,

When you were working with her - were you working with the laptop while connected to your network?

Also have you tried setting up that account on a different machine?

Given your feedback, I'm very much suspicous that there's a firewall problem.

I think if you can get it to work on another machine via Thunderbird in your office, we could then at least safely determine that the problem is the laptop (or we would have a great test bed to fix whatever the problem is without needing to involve the original laptop at all).

If we can get it to work on another machine - the next course of trouble shooting could be to help her over the phone disable the laptop firewall and test again.

If it works - then we know what's going on and then provide more pinpointed directions on how to modify the windows firewall to permit this kind of traffic.

This stuff is reallly hard! I know that feeling of total befuddlement. These things should just work :(.

jamie

comment:6 Changed 9 years ago by https://id.mayfirst.org/praxis_web

Hey, Jamie,

Man, this is a fun one, huh? To the degree that it is possible to be certain that you did some thing X when configuring a computer that you then handed off to someone, I am certain that I had Windows Firewall turned off on her machine. As far as networks, go, I tested it on our network and on Sprint's network. (The fact that she uses a Sprint USB modem made it convenient.) I also tested on our network using my EEEBuntu netbook and a Mac OS X Leopard machine that I happened to have lying around.

In none of the cases above did the email address work - there's no firewall blocking access to viewsic.mayfirst.org on our network, and I've connected using the Sprint network before, so I'm terribly confused.

Oddly enough, the address worked on my iPhone. I tried adding it and it went just fine. So, the firewall thing does seem like it could be a problem, but I'm not sure why it would be affecting just one machine.

What do you recommend we do?

Dheeraj

comment:7 Changed 9 years ago by https://id.mayfirst.org/jamie

Ok... can you setup with her account on the mac again?

Then we can try to trouble shoot that installation.

Once you have it setup - try telneting from the mac to be sure you are able to connect to port 993 and then let me know - i can tail the logs while you try to login.

I'm op jabber at jamiem@jabber.net

jamie

comment:8 Changed 5 years ago by https://id.mayfirst.org/ross

  • Keywords email added
  • Resolution set to fixed
  • Status changed from new to closed

Given the length of time since the last comment, I'm going to mark this as resolved. If I am mistaken, please re-open this ticket.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.