Opened 9 years ago

Closed 5 years ago

#1787 closed Bug/Something is broken (fixed)

IBEW 567 Resign Form Not Accepting Sending Submissions

Reported by: support@… Owned by: https://id.mayfirst.org/jamie
Priority: High Component: Tech
Keywords: email Cc:
Sensitive: no

Description

Guys -

It appears that one of our sites, IBew567.com, who has a work resign form at http://www.ibew567.com/book-1-resign-form can suddenly not accept submissions from member signing the form.

The form is critical because they are resigning work lists.

When I checked with Matt he mentioned that their server is blacklisted with Mayfrist and this is affecting their ability to receive email and send email from the site. Could you guys check this out :

http://mxtoolbox.com/blacklists.aspx?ip=209.51.163.201

Change History (6)

comment:1 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi,

Thanks for the report.

It looks like 209.51.163.201 is being listed in several of the sorbs databases.

There are several reasons for these listings - we'll need to work together to get them delisted:

  • The sorbs listing are because sorbs thinks the IP address is a dynamic IP address (like one assigned to a residential ISP customer). sorbs thinks this way because the time to live for the record is less than 12 hours (it's set to 1 hour). I personally think this is ridiculous and we should be able to have time to live values of less than 12 hours, but that's how sorbs works. The domain ibew567.com is not handled by our DNS (it's handled by rsvweb.com). I think switching it to MFPL would be a wise move. If you can't do that, then I would suggest increasing the time to live for the domain name to a higher value. Once you do that, we can submit a request to be delisted.
  • In addition, there was no proper reverse lookup of the IP address. In other words, when a DNS query is made against the IP address it doesn't not present ibew567.com. I've just fixed this - because the IP address is handled by our DNS servers even though the domain name is not.
  • Do not send mass mail from jones (or from any of our regular servers). I just ran the command mailq which shows all messages on jones that have been deferred. I'm seeing a lot of messages that seem to be bulk email sent by ibew102, ibew103, local137, and ualocal716. Instead, configure Drupal to send mass mail via bulk.mayfirst.org. If you use jones to send bulk mail, you increase the likelihood that jones will be black listed, thus preventing non-bulk emails (like password resets or form submissions) from being successfully sent. It's really important for you to distinguish between bulk mail (which will always run the risk of getting blocked) and non-bulk email (which is generally more critical to have delivered in a timely manner).

Please login to support and post a comment to this ticket so I know you got it and are working on the time to live problem. We can't request for the IP to be removed from sorbs until this happens. If you have any questions, please ask so we can get this sorted out.

Thanks!

Jamie

comment:2 follow-up: Changed 9 years ago by https://id.mayfirst.org/doug

Hey Jamie -

Thanks for looking into this, I just tried to reply to this one and not sure you got it or it even went through.

My main question is what do you mean by control of the DNS, I would think this is controlled by register4less.com where it is registered.

Are you referring to being able to edit the DNS to make the changes to time live that you reference in point 1? it appears that while uws is listed as the technical contact, the server edits are being controlled by rsvweb...

Moving forward, is it correct to say that all DNS user registrations and exsiting domains should be handled by UWS and therefore MAyfirst? We can write this into the service agreement if you think it makes sense.

I have asked Robert from RSV to contact you directly to work toward resolution on points 1 and 2. So far as i know, there has been no bulk email sent from this domain.

Doug

comment:3 in reply to: ↑ 2 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi Doug,

Thanks for looking into this, I just tried to reply to this one and not sure you got it or it even went through.

Yup - your message seems to have been successfully posted.

My main question is what do you mean by control of the DNS, I would think this is controlled by register4less.com where it is registered.

Every domain name is registered with a domain registrar (like Dotster, Tucows, Gandi,Register4Less, etc.). Sometimes, a web hosting company will register the domain name for you (either directly or via a registrar re-seller). However, regardless of how it is registered, every domain name has a registrar.

It's the job of the registrar to define the addresses of the authoritative name servers for your domain. May First/People Link members have domains registered with lots of different registrars, however, almost all of them define the authoritative name servers for their domain as: a.ns.mayfirst.org and b.ns.mayfirst.org, which means we have the ability to change the dns information for a given domain (such as the time to live).

IBew567.com is registered with Tucows (via a reseller - probably register4less), and has the authoritative dns servers defined as: ns3.rsvweb.com and ns4.rsvweb.com.

For more info on domain names, you might be interested in our dns primer.

Are you referring to being able to edit the DNS to make the changes to time live that you reference in point 1? it appears that while uws is listed as the technical contact, the server edits are being controlled by rsvweb...

Yes -that's what I'm referring to and yes it does seem to be controlled by rsvweb.

Moving forward, is it correct to say that all DNS user registrations and exsiting domains should be handled by UWS and therefore MAyfirst? We can write this into the service agreement if you think it makes sense.

Yes - I think that's important.

I have asked Robert from RSV to contact you directly to work toward resolution on points 1 and 2. So far as i know, there has been no bulk email sent from this domain.

Great - please point him in the direction of this ticket so he can comment on it.

Thanks!

jamie

comment:4 follow-up: Changed 9 years ago by https://id.mayfirst.org/doug

Jamie -

Here is the whole chain. The client is frustrated cause they dont know ehre the problem lies and I have to say I really dont either. My sense is you guys made the changes you needed to make to the Reverse DNS look-up and the rest was on the registrar, which based on your explanation below, I understand to be Rivas _ the rsv web server that hosts their email. So i would just like to get back to them with a clear assesment of the problem, I can be the point on our end to eliminate confusion.

I know that when i edit the page on the resign form at ibew567.com http://www.ibew567.com/book-1-resign-form -- and list myself as the contact, I DO get the emails. For soem reason, when I shift the form recipient back to ashepard@… , he does NOT get them. So we are constantly going back and forth with Rivas saying the site is not generating the emails (it clearly is to me at doug@… ) in the first place since he doesnt see them on his server that hosts their email, and us saying that he needs to make these adjustments to the name server records which he claims he has.

Anything I can do to help I will do, including having you talk to Matt or Brendan or the Open Concept guys, at this point i would simply like to understand what we need to do to get it working.

I can also have Rivas contaxt you directly or maybe you can contact him? Phone Call? Just let me know what I need to do...

Doug

I'll forward this on to Doug and maybe we can get this resolved.

Dick

From: Robert D. Rivas robert@… Sent: Wednesday, February 18, 2009 2:40 PM To: ddeering@…; 'Doug McCabe' Subject: RE: web email

Dick,

Again, the key point here is that all of the email (regardless of who is sending it) from the UWS server is not getting to our mail server, which is why you don't get the messages.

The issue isn't that our mail server is not delivering it, it is that we aren't getting a message at all either. This problem is originating from the source server at Mayfirst, which UWS uses for hosting the ibew567.com website itself, not from the server you have running your email for the office.

A way to test this is to have the user who calls you send an email to your office directly, and not through the form. If you get the email then the mail service is working as intended.

Thanks! Robert

From: Dick Deering ddeering@… Sent: Wednesday, February 18, 2009 1:57 PM To: robert@…; Doug McCabe Subject: RE: web email

The problem occurred during the time after January resign and before February resign. Prior to that, all was ok. The web page email source never makes it to our office email accounts, whether we are on line in the office or at home. None of the test emails to Alan from Doug, me, Don, or Sara directed to each other here in the office, or any of the resigns from members that originate from all over America are getting to these office computers. Internal office emails routed through the web page are not the only issue.

From: Robert D. Rivas robert@… Sent: Wednesday, February 18, 2009 1:40 PM To: ddeering@…; 'Doug McCabe'; 'Robert D. Rivas' Subject: RE: web email

Dick,

Doug has sent a test to me and I have received it a couple of times, so it looks like outbound is working correctly, just not to ibew in the office.

With that said, I don't see any email coming in to our server (where your email is served from) so if we don't get an email, then obviously we can't deliver anything.

What I suspect is happening is that when you send an email to yourselves (anyone with an ibew567.com email address) the web server that UWS uses is keeping the email internal and not routing it to the outside world. What we need to do is verify that the server sees mail.ibew567.com as follows:

mail.ibew567.com [24.39.26.53]

If it sees it as anything other than this then that is the issue. Again, having two different services is part of our issue as well, I can't log-on to their server, as well Doug isn't able to log-on to ours, so I have no way of checking my theory out. Because you are getting email from everywhere else, I don't see any issue on our end, this really needs to be worked on form the UWS end.

Thanks, Robert

From: Dick Deering ddeering@… Sent: Wednesday, February 18, 2009 9:08 AM To: Doug McCabe; Robert D. Rivas Subject: web email

Doug, Robert

We still are not receiving email that originates at our web page. Alan has not received any test emails or resigns sent from www.ibew567.com by anyone from here or away. Please help.

Dick Deering

Business Manager

IBEW Local 567

comment:5 in reply to: ↑ 4 Changed 9 years ago by https://id.mayfirst.org/jamie

Hi Doug,

It looks like they are two problems:

  • ibew567.com is being blacklisted on sorbs. Please ask the DNS administrators for ibew567.com to increase the time to live record for mail.ibew567.com from 14400 to minimally 43200. Once they have increased the time to live, the domain can be de-listed.
  • On January 26 it appears as though someone added email addresses to the ibew567.com account on jones. jones is not handling email for ibew567.com (mail is being handled off site). However, when you add email records to jones, jones thinks it should handle the email. So - if you send a messages via jones to an ibew567.com email address, jones will try to deliver it locally (and fail). I just removed these records, so now when you try to send a message to an ibew567.com address it should be properly delivered.

Can you try it again and let us know how it goes?

Jamie

comment:6 Changed 5 years ago by https://id.mayfirst.org/ross

  • Keywords email added
  • Resolution set to fixed
  • Status changed from new to closed

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.