Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#16463 closed Bug/Something is broken (worksforme)

EtherCalc Not Usable

Reported by: Mikayla Biggers Owned by: Jamie McClelland
Priority: Medium Component: Tech
Keywords: ethercalc calc.mayfirst.org connection-timeout socket Cc:
Sensitive: no

Description

I use MayFirst's EtherCalc service at as a crucial part of organizing against the Line 3 pipeline, but for roughly the last week, the service has been unusable. Frequently, the software sends a pop-up error message to the screen that says "Connection timeout; please refresh to try again." When I do reload the page, none of the changes that I had recently made to the spreadsheet are saved. The fact that this is constantly happening without any changes as far as I've noticed means it is impossible to update any EtherCalc sheets right now, and has been for the last week. I'm fairly confident this isn't an issue on my end, as my internet connection has been quick and reliable when using any other websites. If you could look into this as soon as possible, I would greatly appreciate it!

Attachments (1)

Screenshot 2021-05-03 132858.png (6.2 KB) - added by Mikayla Biggers 3 months ago.
The error displayed periodically when using EtherCalc

Download all attachments as: .zip

Change History (8)

Changed 3 months ago by Mikayla Biggers

The error displayed periodically when using EtherCalc

comment:1 Changed 3 months ago by JaimeV

Owner: set to Jamie McClelland
Status: newassigned

Hi Mikayla,

Thanks for opening this ticket. The ethercalc instance does not see heavy usage and I don't think we would have known about this issue otherwise. I am copying my coworker jamie here and providing some extra technical details for him:

jamie I am able to connect to https://calc.mayfirst.org and I am not seeing any immediate issues however the simple test documents I am creating probably do not create the same conditions.

The ethercalc systemd service doesn't report any errors. I see some related errors in apache logs:

[Mon May 03 18:17:37.799836 2021] [proxy_http:error] [pid 26076:tid 140222243247872] (20014)Internal error (specific information not available): [client 75.72.151.27:50980] AH01102: error reading status line from remote server localhost:8000

I'm not sure how else to debug this.

comment:2 Changed 3 months ago by Jamie McClelland

I'm sorry this is happening. Would you mind creating a new spread sheet, entering data in it until it reaches a point where you experience this problem and then sharing the link with us? I'd like to resolve this if possible.

There is a newer version of ethercalc available, so we can always try upgrading, but I'd like to be able to replicate the problem before hand so we can be more sure we have fixed it.

comment:3 Changed 3 months ago by Mikayla Biggers

Keywords: socket added
Priority: UrgentMedium

comment:4 in reply to:  2 Changed 3 months ago by Mikayla Biggers

Replying to Jamie McClelland:

I'm sorry this is happening. Would you mind creating a new spread sheet, entering data in it until it reaches a point where you experience this problem and then sharing the link with us? I'd like to resolve this if possible.

So I mainly use my desktop Windows 10 PC, which is where I noticed the issue. I decided to try troubleshooting on my Windows 10 laptop to see if anything changed, since neither you nor Jaime were noticing the same issue when troubleshooting. What I found is that the EtherCalc instance hosted by the collective works exactly as expected on my laptop, and I was able to both edit existing spreadsheets and create a large, entirely-new spreadsheet without any issues in saving data or anything else.

I then went back to my desktop, where the problem persists with existing spreadsheets, and is so omnipresent even with new spreadsheets that it prevents me in saving any data to a spreadsheet once I've created it. Another thing I noticed is that, when loading a page from https://calc.mayfirst.org, the desktop takes an abnormally long amount of time to load while displaying the Chrome browser message "Waiting for available socket..." in the bottom-left corner.

So, a couple thoughts: 1) this seems like much less of an intractable problem than I initially thought, so I downgraded the ticket priority from "Urgent" to "Medium"; and 2) I'm at a loss for why this is happening 100% of the time on my desktop, but hasn't happened on my laptop in today's session. Both are Windows 10 computers, both are using the most up-to-date version of the Chrome browser, both are wirelessly connected to the same WiFi source, and both are very capable of using any other web program with ease.

Do you have any possible leads on what may be causing this strange issue?

EDIT: I was just doing some EtherCalc spreadsheet work on my laptop computer after posting this, and noticed the same problem happening there now as well. To be clear, the "Connection timeout" error is one I have seen occur many times over multiple devices over the past few months, but it had never been as unavoidable or omnipresent as it now is on my desktop PC. Previously, my solution was to just wait until another time where it seemed the server connection was more stable. However, it would certainly be nice to never have to deal with this issue again! Unfortunately, due to the weird and sporadic nature of this issue, I'm not sure how to reproduce it in a way that you will certainly be able to observe, regardless of whatever unknown circumstances cause the issue to appear.

In case it might help, here is a test spreadsheet I made on my laptop where I have now observed the issue happening there: https://calc.mayfirst.org/2ut8g63t0lr6

Last edited 3 months ago by Mikayla Biggers (previous) (diff)

comment:5 Changed 3 months ago by Jamie McClelland

I'm still not able to replicate ... but after investigating more, I noticed some errors in my console when running via Firefox about not being able to connect to an url with "sockiet.io" in it. I seemed to have fixed that by updating the apache config file to include some rewrites to handle these kind of URLs.

I also struggled to upgrade to the most recent version of ethercalc. This was challenging since the version of npm that ships with buster won't upgrade because our version of nodejs was too old.

I finally installed nvm locally via the calc user and then ran npm to update ethercalc.

Then, for some reason, ethercalc expects to find node_modules in ~node_modules/ethercalc/node_modules, but npm installs them in ~/.node_modules - so I added a symlink in ~/node_modules/ethercalc/node_modules -> ~/node_modules and now it seems to be working.

I'm not sure if any of this has fixed the proble you were experiencing or not. Let us know!

comment:6 Changed 3 months ago by Mikayla Biggers

Resolution: worksforme
Status: assignedclosed

Ok, so after over a week of using EtherCalc since Jamie made some changes, me and my team aren't noticing the same issue (trouble connecting to the server to update spreadsheets) anymore. As far as we can tell, it works, but given that the problem was sporadic in the first place, I'm not sure if I want to fully call this one "fixed" yet. I wouldn't be that surprised if it popped up again in a week.

Thank you for your hard work, Jamie!

comment:7 Changed 3 months ago by Jamie McClelland

Thanks for the feedback! Glad it is working so far - please re-open if the issue pops back up again.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.