Opened 6 months ago

Closed 6 months ago

#16377 closed Bug/Something is broken (fixed)

PHP fatal error

Reported by: Lu Pa Owned by: Jamie McClelland
Priority: Urgent Component: Tech
Keywords: Email-Errors Cc:
Sensitive: no

Description

When someone configure auto-answer, we are receiving this email:

<marXXXXX@proudhon.mayfirst.org> (expanded from <mXXXXX@tedic.org>):
    Command died with status 255:
    "/usr/local/share/red/node/sbin/red-auto-responder". Command output: PHP
    Deprecated:  The each() function is deprecated. This message will be
    suppressed on further calls in
    /usr/local/share/red/node/sbin/red-auto-responder on line 93 PHP Fatal
    error:  Uncaught PDOException: could not find driver in
    /usr/local/share/red/node/sbin/red-auto-responder:153 Stack trace: #0
    /usr/local/share/red/node/sbin/red-auto-responder(153): PDO->__construct()
    #1 /usr/local/share/red/node/sbin/red-auto-responder(60):
    red_auto_responder->_initialize_sqlite_database() #2
    /usr/local/share/red/node/sbin/red-auto-responder(40):
    red_auto_responder->send() #3 {main}   thrown in
    /usr/local/share/red/node/sbin/red-auto-responder on line 153

Change History (4)

comment:1 Changed 6 months ago by JaimeV

Owner: set to Jamie McClelland
Status: newassigned

Let's get jamie's help with this.

comment:2 Changed 6 months ago by Jamie McClelland

I'm really sorry for that ugly error. I *think* the problem is that php7.4-sqlite3 was inadvertently removed.

I've just re-installed it. Can you let us know if the auto responder is working now?

Jaime - I think php7.4-sqlite3 is another package we will need to specify in puppet.

comment:3 Changed 6 months ago by Lu Pa

Hi !!

Error didn't appear anymore.

The only weird issue is when I write from same domain xxxxxx@… then the auto answer didn't come.

I'm not sure if this is the desired behavior or it's kind a bug.

Thanks!!

comment:4 Changed 6 months ago by Jamie McClelland

Resolution: fixed
Status: assignedclosed

I think the installation of the package fixed it. The autoresponder is designed to only respond to the same email address once per week to avoid loops or generating too much email in response to automated messages. Thanks for reporting the problem!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.