Opened 8 months ago

Last modified 8 months ago

#15326 assigned Bug/Something is broken

Is Database on Amilcar Down?

Reported by: Ted Franklin Owned by:
Priority: Urgent Component: Tech
Keywords: Database Connection Cc: ted@…
Sensitive: no

Description

I was working on bonnielockhart.com, one of the two websites on my account, and out of the blue received the following message: Error establishing a database connection

This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost. This could mean your host’s database server is down.

Are you sure you have the correct username and password? Are you sure you have typed the correct hostname? Are you sure the database server is running?

PLEASE NOTE: This was in the middle of a session. I now receive this message when I try to log in to either of the sites using https://siteURL/wp-admin. To me the fact that neither site is functional suggests that there is nothing wrong with my wp-config.php as I did not edit in the wordpress site that first went down and I did nothing that would alter the wp-config file in the ecosoc.net website.

Change History (4)

comment:1 Changed 8 months ago by JaimeV

Hi. We had a huge resource usage spike on amilcar which caused all database connections to pile up. It seems to be doing better now.

comment:2 Changed 8 months ago by JaimeV

Resolution: fixed
Status: newclosed

comment:3 Changed 8 months ago by Ted Franklin

Resolution: fixed
Status: closedassigned

This appears to be happening again. On several occasions over the past week, WordPress suddenly started acting strangely. Of course, at first, I always think I've done something to provoke it, but now I'm starting to suspect that these are just problems with the Amilcar database. I have not yet figured out whether there is any place where problems with Mayfirst's servers are reported to the community. Is there a plan to resolve the problem of usage spikes? Are these caused by members of our community or are they caused by outside forces? Unfortunately, the website I was working on is also unreachable. I can take the rest of the evening off, but the website is down when Amilcar's database so that is a real problem.

comment:4 Changed 8 months ago by Jamie McClelland

I'm really sorry for the downtime - we seem to experiencing occassional bursts in disk I/O that get into some kind of vicious circle and require some intervention to control. We have made good progress in the last week resolving these issues but we still have some work to do.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.