Opened 5 days ago

Closed 4 days ago

Last modified 3 days ago

#15209 closed Bug/Something is broken (fixed)

yippie stuck in 'pending-insert'

Reported by: Ross Owned by: Jamie McClelland
Priority: Medium Component: Tech
Keywords: control-panel red yippie.mayfirst.org Cc:
Sensitive: no

Description

Hi all,

I'm having a problem on yippie with this red item:

https://members.mayfirst.org/cp/index.php?area=hosting_order&service_id=2&hosting_order_id=509&action=edit&item_id=305883

It's stuck in 'pending-insert'. When I remove the lock directory and run 'red-node-update' I get the following error message:

PHP Fatal error:  Cannot unset $this in /usr/local/share/red/node/share/src/modules/class.red_item_email_address_node_postfix.inc.php on line 31

Any ideas how to resolve this or what could be the culprit?

Thanks, ~/ross

Change History (3)

comment:1 Changed 5 days ago by JaimeV

Owner: set to Jamie McClelland
Status: newassigned

Let's get jamie's help with this.

comment:2 Changed 4 days ago by Jamie McClelland

Resolution: fixed
Status: assignedclosed

Should be working now. I think i've removed that last of the unset($this)'s from the codebase. I seem to have used that as a way to cause the code to throw an error if it detected a problem. However, it seems that some how that is getting detected on some operations. It should only happen if we fail to properly parse the config file.

In any event, let me know if you still have any problems.

comment:3 Changed 3 days ago by Ross

I think I figured out what happened. I believe I changed the php cli to 7.2 so I could work with composer, which likely caused the weirdness that you experienced. I'm assuming this, because composer was broken when I went to use it.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.