Opened 3 months ago

Closed 2 months ago

#14335 closed Bug/Something is broken (fixed)

List issue

Reported by: https://id.mayfirst.org/bexhh Owned by: https://id.mayfirst.org/jaimev
Priority: Urgent Component: Tech
Keywords: Cc:
Sensitive: no

Description

Hi, I received this error message when trying to turn OFF DIGESTING for a list. Can you help me figure out what I need to do in order to correct the issue?

ERROR MESSAGE Warning: The following illegal substitution variables were found in the msg_footer string: user_address, user_optionsurl

Your list may not operate properly until you correct this problem.

Thank you!

Change History (4)

comment:1 Changed 3 months ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

Hi I'm very sorry this ticket was overlooked as well. I think the above error is in reference to the msg_footer variable that can be set for your list through the mailman interface. What is the list name?

Last edited 3 months ago by https://id.mayfirst.org/jaimev (previous) (diff)

comment:2 Changed 3 months ago by https://id.mayfirst.org/tinygig

Hi, I believe it was for "wcdmzsteering" - although, I do not see the error message at this moment. Do you know how I can test if it's still a present error?

thanks!

comment:3 Changed 3 months ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to feedback

Hi - I just turned on "personalization" here:

https://lists.mayfirst.org/mailman/admin/wcdmzsteering/nondigest

I suspect that is the cause of the error. Here's the explanation of the setting:

Normally, Mailman sends the regular delivery messages to the mail server in batches. This is much more efficent because it reduces the amount of traffic between Mailman and the mail server.

However, some lists can benefit from a more personalized approach. In this case, Mailman crafts a new message for each member on the regular delivery list. Turning this feature on may degrade the performance of your site, so you need to carefully consider whether the trade-off is worth it, or whether there are other ways to accomplish what you want. You should also carefully monitor your system load to make sure it is acceptable.

Select No to disable personalization and send messages to the members in batches. Select Yes to personalize deliveries and allow additional substitution variables in message headers and footers (see below). In addition, by selecting Full Personalization, the To header of posted messages will be modified to include the member's address instead of the list's posting address.

======

I'm not 100% how to test it without simply sending a message.

Also, we generally turn on personalization despite the warnings about performance because it allows for a personalized opt out URL.

comment:4 Changed 2 months ago by automatic

  • Status changed from feedback to closed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.