Opened 5 weeks ago

Closed 2 weeks ago

#14233 closed Bug/Something is broken (fixed)

Update server to PHP 7.1?

Reported by: https://id.mayfirst.org/dac Owned by: https://id.mayfirst.org/jaimev
Priority: Urgent Component: Tech
Keywords: Cc: https://id.mayfirst.org/jamie
Sensitive: no

Description

Hi all,

For the CountEveryVote site, we need to update the PHP version to (at minimum) 7.1. Is this something y'all can change on your end? We were planning on launching right around now, and I just uploaded the site, only to see that the PHP version the server is running is too low.

Thanks!

Change History (6)

comment:1 Changed 5 weeks ago by https://id.mayfirst.org/jaimev

  • Cc https://id.mayfirst.org/jamie added
  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

We don't have php 7.1 installed on any of our shared servers as we are running the version of php available with Debian stable. I'm not sure how we could do this unless you were on a dedicated server running a 3rd party packaged version of php 7.1 or higher.

Copying jamie for more input.

comment:2 Changed 4 weeks ago by https://id.mayfirst.org/jamie

This is our second request involving a php version higher than 7.0. I think we will need to make 7.2 available through third party repositories. We'll probably need about a week to make this happen though. Can you wait that long?

comment:3 Changed 4 weeks ago by https://id.mayfirst.org/dac

Thanks Jamie and Jaime!

Yes, a week should be okay—for now, we've exported the site as a static site so that we can get something up quickly. (This is around the voter suppression in Georgia and Florida, hence the rush to get it up). There are plans to expand this site, but we should be able to continue to use this static version of the site for the next week.

Thanks so much for working on this!

comment:4 Changed 4 weeks ago by https://id.mayfirst.org/jamie

#14235 Great - glad to hear. I just opened a ticket to track our progress: #14235

comment:5 Changed 4 weeks ago by https://id.mayfirst.org/jamie

Woops. My week estimate didn't take into account the holiday weekend. I may need another week.

I have completed the hardest part - selection of php version is now available to users via the control panel (5.6 and 7.0 are the only choices).

Next week I should have time to install 7.1 and 7.2 and ensure those selections will work and then we can push it out to all servers.

comment:6 Changed 2 weeks ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to closed

This task is now complete - both 7.1 and 7.2 are now available via the control panel.

You can edit your web configuration, click the Advanced Options button, and scroll down to the bottom to choose your preferred version of PHP.

Please give it a shot and let us know if you experience any problems!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.