Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#13996 closed Bug/Something is broken (fixed)

Site down, getting an error that says my "PHP installation appears to be missing the MySQL extension which is required by WordPress"

Reported by: https://id.mayfirst.org/shirari Owned by: https://id.mayfirst.org/jaimev
Priority: High Component: Tech
Keywords: wordpress, php, mysql Cc:
Sensitive: no

Description

Hello, our website http://empoweredthemovie.com/ and our Wordpress dashboard are down and are showing me an error, "Your PHP installation appears to be missing the MySQL extension which is required by WordPress." Not sure when this happened, I hadn't checked the site in a while and just came across the issue late last week. After looking at my May First control panel and the help documentation here, I still can't figure out what I can do to fix this. Thank you for any ideas!

Change History (7)

comment:1 Changed 3 months ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

It looks like this might be related to our recent upgrade to PHP version 7. You wordpress site appears to be very outdated. If you agree I can try forcing the site to upgrade to the newest version.

comment:2 Changed 3 months ago by https://id.mayfirst.org/shirari

That would be great, thank you - sorry I've let it get so out of date. Is there any way you can do a database backup for me first? I just backed up the wp-content stuff via FTP but I'm not sure how to backup the database...

comment:3 Changed 3 months ago by https://id.mayfirst.org/jaimev

Nightly database dumps are placed in the empoweredthemovie.com/backups folder you can access via sftp. I'll go ahead with the upgrade attempt now.

comment:4 Changed 3 months ago by https://id.mayfirst.org/shirari

Hm, it won't let me access that folder. I guess I'll just hope for the best. Thank you for your help!

comment:5 Changed 3 months ago by https://id.mayfirst.org/shirari

  • Resolution set to fixed
  • Status changed from assigned to closed

Hey, what you did worked - the site is back up! Thank you so much for rescuing it for us!

comment:6 Changed 3 months ago by https://id.mayfirst.org/jaimev

The upgrade was successful but some of your installed plugins did not have new updates available and at least on "audio-player" was not compatible with the new version of PHP and had to be deactivated.

comment:7 Changed 3 months ago by https://id.mayfirst.org/jaimev

You should be able to access the backups folder with the empowered user.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.