Opened 2 months ago

Closed 4 days ago

#13948 closed Bug/Something is broken (fixed)

create dedicated mosh for highlander and move hosting order

Reported by: https://id.mayfirst.org/jamie Owned by: https://id.mayfirst.org/jaimev
Priority: Medium Component: Tech
Keywords: Cc:
Sensitive: no

Description

Highlander is planning to move all email to MF/PL, which is going to be a lot and has agreed to move to a dedicated server.

Their current highlander.org web site is on floriberto.

I suggest we start their dedicated mosh with 4GB of RAM and 150GB of disk space.

Change History (9)

comment:1 Changed 2 months ago by https://id.mayfirst.org/jamie

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

Hi Jaime - would you mind taking this one on?

I did some research to come up with names for the servers I created today and have a few left over (some we have used in the past but no longer are using so they could be brought back): Maya Angelou, Harvey Milk, WEB Dubois, Ida B Wells, Audre Lorde

comment:2 Changed 2 months ago by https://id.mayfirst.org/jaimev

Hi, I am installing maya.mayfirst.org on medgar and running into issues with mf-add-routes failing on first push from puppet. We saw this in #13497 and had to make some adjustments but they are not documented there. Do you remember what this was about?

comment:3 Changed 2 months ago by https://id.mayfirst.org/jamie

Yeah - I saw those as well. I think the problem is that we need a reboot after the first puppet push so that the network interface can get properly renamed.

In puppet we create a udev rule that renames the network device based on the mac address, and the rest of the puppet scripts depend on that new name. So, a reboot solves the problem.

A more elegant solution would be to try to research a udev command that would trigger the rule to be applied - then that could run via puppet when the udev rule is first created.

comment:4 Changed 2 months ago by https://id.mayfirst.org/jaimev

The new mosh maya is ready now.

comment:5 Changed 2 months ago by https://id.mayfirst.org/jaimev

Do we want to add an ssd volume for /var/lib/mysql to this mosh?

comment:6 Changed 2 months ago by https://id.mayfirst.org/jamie

Thank you! And yes, let's allocated mysql via the ssd. And, can you please move the hosting order highlandercenter.org from floriberto to the new host?

They are not using us for mail or web - so you can move it when ever you want (they are using those use accounts for next cloud though).

comment:7 Changed 4 days ago by https://id.mayfirst.org/jamie

Hi Jaime - just a reminder about getting this done today if at all possible. Thanks!!

comment:8 Changed 4 days ago by https://id.mayfirst.org/jaimev

This is done now. Sorry for the delays.

comment:9 Changed 4 days ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.