Opened 6 months ago

Closed 5 months ago

#13817 closed Question/How do I...? (duplicate)

Trouble Setting Up WordPress FTP for Auto-Update

Reported by: https://id.mayfirst.org/devinvnetwork Owned by: https://id.mayfirst.org/jaimev
Priority: Medium Component: Tech
Keywords: wordpress, ftp, update Cc:
Sensitive: no

Description

Hi. I'm trying to set up WordPress core updates at a website /wp-admin/update-core.php?action=do-plugin-upgrade

I keep getting the error "Failed to connect to FTP Server www.erica.mayfirst.org:21"

I'm using the same FTP Server, Username and Password as I'd use in Filezilla but it isn't working. Any ideas for what I'm doing wrong? Thanks.

Change History (4)

comment:1 Changed 6 months ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

Your login credentials only work for sftp access not ftp. However, you shouldn't need to add ftp access to perform regular wordpress updates. Unless there is something wrong with your file permissions wordpress should be able to write those updates directly. Were you unable to apply updates?

comment:2 Changed 6 months ago by https://id.mayfirst.org/devinvnetwork

I can't use the automatic update feature. You can see the error here: https://drive.google.com/file/d/1q3l2-Rr6LXuxT27BtNnfjBBS4-HCeWhV/view?usp=sharing

I tried with FTP and "FTPS".

Thanks.

comment:3 Changed 5 months ago by https://id.mayfirst.org/jamie

I'm scratching my head on this one. I found a blog that describes what is happening - in other words, your Wordpress site thinks it can't write to the web directory, so it is asking you for FTP credentials.

However, assuming you are working on the g0v.network those permissions are properly set.

In theory, secure FTP should work as well (but you should remove the "www" in front of erica.mayfirst.org and the port number should be 22 instead of 21, so maybe properly secure ftp is not really implemented).

Can you confirm the site you are working on? And also if you can show the screen prior to getting the one prompting you for your ftp credentials that would be great.

comment:4 Changed 5 months ago by https://id.mayfirst.org/jaimev

  • Resolution set to duplicate
  • Status changed from assigned to closed

jamei I think this is a duplicate of recent additions to #4498 , although I should have answered here instead. The underlying issue was file ownership. ftp updates shouldn't be necessary on our servers.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.