Opened 4 months ago

Closed 4 months ago

#13781 closed Bug/Something is broken (invalid)

php update for srlp.org

Reported by: https://id.mayfirst.org/tadpole Owned by: https://id.mayfirst.org/jamie
Priority: Medium Component: Tech
Keywords: Cc:
Sensitive: no

Description

srlp.org is currently runniong on php 5.6. Is it possible to upadte to php 7.1?

Change History (7)

comment:1 Changed 4 months ago by https://id.mayfirst.org/jamie

Not this moment - but since you are on a dedicated MOSH we can definitely schedule your upgrade to happen. If it's urgent we can try to squeeze it in this week but since we have a busy conference with the Allied Media Conference it would be much easier to plan it for Wednesday, June 20th (around 8:00 pm Eastern time). Does that work?

comment:2 Changed 4 months ago by https://id.mayfirst.org/jamie

  • Owner set to https://id.mayfirst.org/jamie
  • Status changed from new to assigned

comment:3 Changed 4 months ago by https://id.mayfirst.org/tadpole

Hi,

The 20th at 8pm will work for us.

Can you confirm that you will be doing backups, then upgrading and testing after the upgrade is complete?

Thanks,

kevin

comment:4 Changed 4 months ago by https://id.mayfirst.org/jamie

All data is backed up every morning - and upgrading the server from Debian Jessie to Debian Stretch won't impact the data (it's not like a Drupal upgrade where the database has to be upgraded to the new version in a non-reversible way).

If you are worried about testing the site in PHP 7.0 - I would suggest that I complete the upgrade but leave your site running php 5.6. Then I can explain how you can switch back and forth between php5.6 and php 7.0 - so you can fully test to make sure all functions are working in php 7.0.

comment:5 Changed 4 months ago by https://id.mayfirst.org/tadpole

Hi,

It's more about having backups 'just in case'.

If we can set the server up to switch between versions that would be optimal. We are doing a test of the site on php through 7.2 but if we had the option to switch that would be much appreciated.

comment:6 Changed 4 months ago by https://id.mayfirst.org/tadpole

Hi,

We did do a test of the srlp.org website on php 7.0, 7.1 , and 7.2. Unfortunately the site has a theme that will not work past php 5.6.

Can we cancel the update and once they are ready we can reschedule?

Thanks,

Kevin

comment:7 Changed 4 months ago by https://id.mayfirst.org/jamie

  • Resolution set to invalid
  • Status changed from assigned to closed

Good catch. Sure, we can cancel the upgrade. Just re-open when you are ready to go.

Note - at some point this summer we will be upgrading all servers - however, I have coded the srlp.org web site to remain on php5 even after the upgrade (that will be good through December 31, 2018 - which is the last date we will support php 5.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.