Opened 16 months ago

Last modified 15 months ago

#13309 assigned Bug/Something is broken

drush cache-rebuild not working

Reported by: https://id.mayfirst.org/leftforum Owned by: https://id.mayfirst.org/jaimev
Priority: High Component: Tech
Keywords: Cc: marcus@…, gabriel_morales_96@…
Sensitive: no

Description

Hello I tried to execute drush cache-rebuild because we have an error on our dev.leftforum.org page which I tried to fix I only got this:

Command cache-rebuild needs a higher bootstrap level to run - you [error] will need to invoke drush from a more functional Drupal environment to run this command. Command cache-rebuild requires Drupal core version 8+ to run. [error] The drush command 'cache-rebuild' could not be executed. [error]

Change History (8)

comment:1 Changed 16 months ago by https://id.mayfirst.org/leftforum

  • Cc marcus@… added

comment:2 Changed 16 months ago by https://id.mayfirst.org/leftforum

Another question is Composer installed on the server?

https://www.drupal.org/docs/develop/using-composer/using-composer-with-drupal

comment:3 Changed 16 months ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

composer is not installed globally on the server. There is no debian package available for composer for the current version of the operating system however it will be available when we upgrade to the new version of debian.

It is also possible to install composer manually locally or globally. I can help you with that if you need it.

comment:4 Changed 16 months ago by https://id.mayfirst.org/leftforum

Last edited 16 months ago by https://id.mayfirst.org/leftforum (previous) (diff)

comment:5 Changed 15 months ago by https://id.mayfirst.org/leftforum

  • Cc abriel_morales_96@… added
  • Priority changed from Medium to High

Hello Jaimev,

can we install Composer so that we can use it for the new site we are working on. It makes it safer when we develop with a bunch of people.

marcus

comment:6 Changed 15 months ago by https://id.mayfirst.org/leftforum

  • Cc gabriel_morales_96@… added; abriel_morales_96@… removed

comment:7 Changed 15 months ago by https://id.mayfirst.org/jamie

  • Resolution set to fixed
  • Status changed from assigned to feedback

Hi Marcus,

I just installed composer for the leftforum-dev user by following the composer download directions.

In addition to running those directions, I also did the following:

  • I put the composer.phar file in your bin directory and renamed it to just composer (mv composer.phar ~/bin/composer)
  • I made it executable: chmod 755 ~/bin/composer

Now, you can run it by simply typing composer

Are you still getting the cache rebuild error?

comment:8 Changed 15 months ago by https://id.mayfirst.org/leftforum

  • Resolution fixed deleted
  • Status changed from feedback to assigned

Cache rebuild works now.

All great so far. Thanks so much for installing composer.

We started building the site already on local machines and will use composer, git etc. now to get it all together and then continue to build the new site.

M

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.