Opened 18 months ago

Last modified 18 months ago

#13129 assigned Bug/Something is broken

Issues With Homepage Slideshow

Reported by: https://id.mayfirst.org/indiakushner Owned by: https://id.mayfirst.org/jaimev
Priority: Urgent Component: Tech
Keywords: albizu, drupal Cc: roger@…, https://id.mayfirst.org/jamie
Sensitive: no

Description

Hi,

I recently performed some security updates to my organization's website and now the homepage slideshow has not only disappeared but there is a large white space where it should be. Also, the buttons to click through the slideshow are now above the white space. I did recently perform a few security updates, including one called Views Slideshow, so not sure if this is the issue. When I navigate to where the security updates list was, it now says: Unresolved dependency, file_entity (Missing). Media requires this module. A coworker has fixed it for now by enabling the Views Slideshow Simple Pager.

He thinks it may or may not be because of the Media module update, that I updated which now is not working properly (it says it is missing the File_entity).

Do you have a solution? If not, could you restore the website until the day before I updated the Media module?

Attachments (1)

cosh-home.png (300.3 KB) - added by https://id.mayfirst.org/jamie 18 months ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 18 months ago by https://id.mayfirst.org/jaimev

  • Cc https://id.mayfirst.org/jamie added
  • Keywords albizu drupal added

I found this thread https://www.drupal.org/node/2909732

And based on that I've tried using drush to install the file_entity module for you. If that doesn't work maybe uninstalling and reinstallling the views_slideshow module and allowing it to install required dependencies might help.

Also copying jamie here for more input.

comment:2 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Now our entire website is down and it says:

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'd7admin_drup.file_metadata' doesn't exist: SELECT * FROM {file_metadata} WHERE fid IN (:fids_0); Array ( [:fids_0] => 442 ) in file_entity_file_load() (line 212 of /home/members/coshnetwork/sites/d7.coshnetwork.org/web/sites/all/modules/file_entity/file_entity.file.inc).

comment:3 Changed 18 months ago by https://id.mayfirst.org/indiakushner

That thread by the way is mine. And it wasn't very helpful.

comment:4 Changed 18 months ago by https://id.mayfirst.org/jaimev

  • Owner set to https://id.mayfirst.org/jaimev
  • Status changed from new to assigned

I've disabled the file_entity module and the site loads again, but we are back to where we started.

comment:5 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Thanks! Good to have our site back up again.

When you said uninstall and then reinstall views_slideshow module, could you explain how to do that? When I click on Modules, I see how to enable modules but not sure how to uninstall.

comment:6 Changed 18 months ago by https://id.mayfirst.org/jaimev

I am not sure how to do that through the admin interface but I am able to do so using the drush command line utility. You would have to login to the host via ssh to use this. It is quite useful.

comment:7 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Also did the website go down because you tried to restore the website until the day before I updated the Media module? Or the day before I updated the Views module?

Changed 18 months ago by https://id.mayfirst.org/jamie

comment:8 Changed 18 months ago by https://id.mayfirst.org/jamie

I assume the web site in question is http://coshnetwork.org/ - is that right? I am able to see a slide show.

The formatting is a bit funny though.

I don't think Jaime has restored anything - and I'm not sure you have told us when you updated any parts of the site.

We can pull backups if you tell us the day you want the backup from (the files and the database) - however, we typically will need you to do the restoration.

comment:9 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Yes that's our website. We had to do a quick fix so the slideshow would appear again. Let me find out what backup we would need.

comment:10 Changed 18 months ago by https://id.mayfirst.org/indiakushner

I was told to ask you to restore the website until the day before I updated the Media module. If the slideshow disappears again, then you might have to restore back to the day before I updated the Views Slideshow module.

comment:11 Changed 18 months ago by https://id.mayfirst.org/indiakushner

On a side note ( not sure if this is related to the updates or not) but when I try to edit a certain page, it will only show the page in HTML, not plain text. I tried to add a blog and the formatting menu (where you can add a picture, change the text color etc) is gone. Any idea why?

comment:12 Changed 18 months ago by https://id.mayfirst.org/indiakushner

I believe that I updated the Media Module yesterday at about 9:30 am. I updated the Views Slideshow on Friday Sept. 15th but I'm not sure of the time. Hope that's helpful.

comment:13 Changed 18 months ago by https://id.mayfirst.org/indiakushner

What do you mean specifically when you say I will have to do the restoration?

comment:14 Changed 18 months ago by https://id.mayfirst.org/jaimev

I've just copied our backups of the database dump and web folder from early morning 9-15-2017 to the home of user d7admin.

I think doing the restore means replacing the web folder contents and database with the version in the backups.

comment:15 Changed 18 months ago by https://id.mayfirst.org/indiakushner

One of our colleagues was trying to fix the issue and enabled the file_entity. Can you please disable it using drush again?

comment:16 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Just wondering if you are able to help as our website is still down. Thanks.

comment:17 Changed 18 months ago by https://id.mayfirst.org/jamie

Sorry for the delay - just disabled it now.

comment:18 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Thank you very much! I really appreciate it.

comment:19 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Hi,

We have someone fixing our site, but need some help. Our wysiwyg isn't workig and he says there needs to be a library installed on the server. Can you explain how to get ftp or sftp access on mayfirst? He needs access to the files and folders.

comment:20 Changed 18 months ago by https://id.mayfirst.org/jaimev

Yes, we have a FAQ that explains how to use sftp to connect to your host https://support.mayfirst.org/wiki/faq/files/sftp

Your account with server access in this case is d7admin, for the d7.coshnetwork.org hosting order you should be able to confirm this through the control panel and make any necessary password changes there.

comment:21 Changed 18 months ago by https://id.mayfirst.org/indiakushner

Got it, thanks!

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.