Opened 3 years ago

Closed 3 years ago

#12098 closed Bug/Something is broken (fixed)

Our website is down

Reported by: Sha Grogan-Brown Owned by: Jamie McClelland
Priority: Urgent Component: Tech
Keywords: Cc:
Sensitive: no

Description (last modified by Sha Grogan-Brown)

Strange thing is happening with our website today -- the homepage works fine, but when you click on any link or try to go to a sub-page, it gives HTTP Error 500 and says "ggjalliance.org is currently unable to handle this request."

Any idea what is going on and how to fix it?

Attachments (1)

Screen Shot 2016-09-09 at 1.34.20 PM.png (63.1 KB) - added by Sha Grogan-Brown 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Sha Grogan-Brown

comment:1 Changed 3 years ago by Sha Grogan-Brown

Description: modified (diff)

comment:2 Changed 3 years ago by Jamie McClelland

Owner: set to Jamie McClelland
Status: newassigned

The site should be working now.

The problem seems to have been triggered by our normal drupal upgrade process (since you are using our central drupal installation, you never have to worry about drupal upgrades - we always handle those and your site gets them automatically).

This morning we upgraded from Drupal 7.44 to 7.50.

And, something went wrong. The error in your log was:

[Fri Sep 09 15:24:52.169397 2016] [proxy_fcgi:error] [pid 816:tid 139824925169408] [client 31.24.34.89:34014] AH01071: Got error 'PHP message: PHP Fatal error: Cannot redeclare class InsertQuery in /xxxxxxxxxxxxxxx/web/includes/database/query.inc on line 728\n'

That means Drupal was trying to run the same piece of code twice, which usually means a caching issue (it's somehow being run via the cache and also via the filesystem).

Typically, it can be fixed by flushing the cache. But that wasn't working with your site (I have seen at least one other site with this problem since the upgrade and flushing solved it).

So, I restored your site from backup - both the code and the database.

Frustratingly, I still got the error, which made me question whether the problem was related to the upgrade after all.

Finally, I rebooted the web server and the PHP process manager and it went away, which is very unusual (and makes me think that restarting apache/php might have solved the problem prior to downgrading).

comment:3 Changed 3 years ago by Jamie McClelland

Resolution: fixed
Status: assignedclosed

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.