Opened 3 years ago

Closed 3 years ago

#11983 closed Bug/Something is broken (fixed)

sharing ownCloud calendar

Reported by: Ying-sun Ho Owned by: JaimeV
Priority: Medium Component: Tech
Keywords: Cc:
Sensitive: no

Description

hey there. i am having trouble with the subscription link for my ownCloud calendar. i keep getting an error message (image attached) after entering my username and password.

any ideas on how to fix this? i think it could be a pretty useful tool for our organization if we can get it working smoothly.

thanks!

Attachments (4)

Screen Shot 2016-07-31 at 10.09.05 PM.png (64.9 KB) - added by Ying-sun Ho 3 years ago.
Screen Shot 2016-08-15 at 12.02.32 PM.png (25.9 KB) - added by Ying-sun Ho 3 years ago.
Screen Shot 2016-08-15 at 12.25.34 PM.png (78.8 KB) - added by Ying-sun Ho 3 years ago.
Screen Shot 2016-08-18 at 3.38.24 PM.png (80.7 KB) - added by Ying-sun Ho 3 years ago.

Download all attachments as: .zip

Change History (31)

Changed 3 years ago by Ying-sun Ho

comment:1 Changed 3 years ago by JaimeV

Owner: set to JaimeV
Status: newassigned

Hi, What software are you using to subscribe to the calendar?

comment:2 Changed 3 years ago by Ying-sun Ho

apple's native calendar app (os x).

comment:3 Changed 3 years ago by JaimeV

https://doc.owncloud.org/server/7.0/user_manual/pim/sync_osx.html

The guide above suggests that a url similar to that below can be imported into the OSX calendar app.

https://share.mayfirst.org/remote.php/caldav/principals/youusernamehere/

comment:4 Changed 3 years ago by Ying-sun Ho

no, sorry. i get the same error. this is while trying to subscribe. when trying to add it as an 'account' i get an 'unable to verify account name or password' error, no matter what server address i use ('manual' configuration) or what combination of server address and server path i use ('advanced' configuration).

comment:5 Changed 3 years ago by JaimeV

What version of OSX are you running? I don't have a mac here so it is difficult to test.

comment:6 Changed 3 years ago by Ying-sun Ho

i'm on 10.11.6, which (i believe) is the latest release.

comment:7 Changed 3 years ago by Ying-sun Ho

hi. just circling back around on this. any ideas/update?

comment:8 Changed 3 years ago by JaimeV

Sorry I haven't managed to get access to an OSX machine to test this with. I would also suggest submitting a question to https://central.owncloud.org/ in the meantime.

Changed 3 years ago by Ying-sun Ho

comment:9 Changed 3 years ago by Ying-sun Ho

fyi, i just tried to add my ownCloud calendar to my google calendar, just to see if i could. no luck there, either. i tried a few different URLs, but always got the error message "Settings Error / Could not fetch the URL." see the new attached screenshot.

  • y

comment:10 Changed 3 years ago by Ying-sun Ho

but i just successfully subscribed in thunderbird.

unfortunately, i do not use thunderbird. hope someone can check this out soon. 😊

comment:11 Changed 3 years ago by Jamie McClelland

Sorry about the confusion, I already documented this.

The URL should be:

https://share.mayfirst.org/remote.php/caldav/calendars/USERNAME/CALENDARNAME

Since my username is jamie and I'm sharing my default calendar, I use:

https://share.mayfirst.org/remote.php/caldav/calendars/jamie/defaultcalendar

You can get the name of the calendar (and the entire link) by navigating to the calendar in the web UI and then clicking the caldav link on the left (image of weird paper clip).

What is the URL that is causing the error in OS X?

comment:12 Changed 3 years ago by Ying-sun Ho

i'm getting the same errors no matter which of these server addresses i use:

https://share.mayfirst.org/remote.php/caldav/calendars/ying-sun.leftroots/personal https://share.mayfirst.org/remote.php/dav/principals/users/ying-sun.leftroots/personal https://share.mayfirst.org/remote.php/dav/principals/users/ying-sun.leftroots/

if i try to subscribe, i get the error in the first attachment. if i try to add it as a caldav account, i get the error in attachment 3 (which i am going to upload right after posting this.

Changed 3 years ago by Ying-sun Ho

comment:13 Changed 3 years ago by Jamie McClelland

comment:14 Changed 3 years ago by Jamie McClelland

And if that doesn't work, try entering just

https://share.mayfirst.org/remote.php/caldav/

comment:15 Changed 3 years ago by Ying-sun Ho

interesting. neither of those works when trying to add a caldav account.

the ?export address works for a subscription (not ideal, as i can't add anything to it in mac calendar), but it a) doesn't ask for authentication information, which is weird, and b) doesn't actually display any of the events. but it at least thinks it has successfully connected.

comment:16 Changed 3 years ago by Jamie McClelland

I haven't given up :).

Since I don't have access to a Mac, I've been working on the Google calendar, however, without much luck. I can't find any documentation that suggests that the Google Calendar can act as a CalDav client (there are plenty of how-tos about getting your calendar client program to access your Google calendar, but no way to get your Google Calendar to access another calendar via caldav).

The closest I have found is the ability to import an ics file and the ability to put in a URL of your ics file.

The later option (while viewing a calendar, on the left-hand side, under "Other calendars" click drop down and then select "add by URL") does not return an error if you give it an URL in this format:

https://USERNAME:PASSWORD@share.mayfirst.org/remote.php/caldav/calendars/USERNAME/CALENDARNAME?export

However, it also doesn't show any items. This URL does work, so I suspect the problem is with Google.

What if you try this URL as a Mac subscription? Maybe the Mac Calendar is not showing items because it doesn't have the user/pass embedded in the URL?

comment:17 Changed 3 years ago by Jamie McClelland

Hm. I just found a video that spells it out step-by-step:

https://www.youtube.com/watch?v=sderr4uotEM

It suggests that URL in the form originally suggested by Jaime above (but not included in your list of attempted URLs in your most recent comment):

https://share.mayfirst.org/remote.php/caldav/principals/ying-sun.leftroots/

comment:18 Changed 3 years ago by Ying-sun Ho

hi. i tried the https://USERNAME:PASSWORD@share.mayfirst.org/remote.php/caldav/calendars/USERNAME/CALENDARNAME?export address. i tried the method prescribed in the youtube video. no matter what, i keep getting "Unable to verify account name or password." (see attached screenshot.)

any ideas? ☹️

Changed 3 years ago by Ying-sun Ho

comment:19 Changed 3 years ago by Jamie McClelland

Some progress. I tried with this URL

https://share.mayfirst.org/remote.php/caldav/principals

And, I got this in the error log:

24.193.127.219 - - [22/Aug/2016:17:34:49 -0400] "PROPFIND /.well-known/caldav HTTP/1.1" 405 3696 "-" "Mac+OS+X/10.11.6 (15G31) accountsd/113"
24.193.127.219 - - [22/Aug/2016:17:34:49 -0400] "HEAD /.well-known/caldav HTTP/1.1" 404 0 "-" "Mac+OS+X/10.11.6 (15G31) accountsd/113"
24.193.127.219 - - [22/Aug/2016:17:34:49 -0400] "PROPFIND /caldav/v2 HTTP/1.1" 405 706 "-" "Mac+OS+X/10.11.6 (15G31) accountsd/113"

Which means we need to redirect /.well-known/caldav to a owncloud friendly URL.

comment:20 Changed 3 years ago by Jamie McClelland

405 is a method not allowed - so I think the mac calendar is depending on a webdav command that apache can't handle.

Jaime: can you try some research to see if you can make any more progress with this lead?

I tested because I had access to a Mac briefly, but I wonder if there is a command line webdav client that might be able to replicate a PROPFIND request to apache?

comment:21 Changed 3 years ago by Jamie McClelland

I've been able to re-create the problem without a mac using the cadaver command line webdav client.

First, create a ~/.netrc file with:

machine share.mayfirst.org
login jamie-test
password XXXXXX

Then, run:

cadaver https://share.mayfirst.org/.well-known/caldav

It seems that the Mac Calendar app is ignore the path you give it and trying to access the calendar using the request URI: /.well-known/caldav.

ownCloud has a Rewrite rule in the .htaccess file:

RewriteRule ^\.well-known/caldav /remote.php/caldav/ [R=301,L] 

That should re-write the request to remote.php/caldav (which does work).

However, either that rewrite rule is not working or the authentication credentials are not getting passed on.

Last edited 3 years ago by Jamie McClelland (previous) (diff)

comment:22 Changed 3 years ago by Jamie McClelland

Ying-Sun - can you try this one more time? I think I made some progress.

It looks like the presence of a .well-known directory (which was created for letsencrypt) interfered with the redirect of .well-known/caldav.

I just removed the .well-known directory and am getting a proper redirect with cadaver.

I'd like to know if that solves the problem for the Mac Calendar as well.

comment:23 Changed 3 years ago by Ying-sun Ho

cool! which version of the server info should i use?

comment:24 Changed 3 years ago by Jamie McClelland

I suggest starting with:

https://share.mayfirst.org/remote.php/caldav/principals/ying-sun.leftroots

However, the real problem appears to be that iCalendar ignores what you put and uses https://share.mayfirst.org/.well-known/caldav anyway.

Hope it works!

comment:25 Changed 3 years ago by Ying-sun Ho

IT WORKS!!!

successfully tested it in os x calendar and iOS calendar. thank you so much!

comment:26 Changed 3 years ago by Ying-sun Ho

unrelated owncloud issue: one of our members is having problems with the client. he opened up a ticket: https://support.mayfirst.org/ticket/12100

if someone could help him, i'd appreciate it greatly. i was not able to solve the problem on my own.

  • y

comment:27 Changed 3 years ago by Jamie McClelland

Resolution: fixed
Status: assignedclosed

Great - glad it's working! And sorry about the other issue falling through the cracks. Looks like Jaime is looking into it now.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.