Opened 3 years ago

Closed 3 years ago

#11838 closed Question/How do I...? (wontfix)

Problem installing civicrm mosaico newletter builder extension

Reported by: Liz Mestres Owned by: JaimeV
Priority: High Component: Tech
Keywords: Cc: Jamie McClelland
Sensitive: no

Description

Hi, I'm trying to install the civi mosaico extension and I get the message. "Imagemagick not installed. Email Template Builder will not work. Extension requires Imagemagick to be installed as php module. Please double check."

I did install the imagemagick module for drupal and, from other tickets, it seems that imagemagick is on mayfirst servers. What am I missing?

I also get this error message:

Notice: Undefined index: method in CRM_Mosaico_Utils::processImg() (line 149 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: params in CRM_Mosaico_Utils::processImg() (line 151 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined offset: 1 in CRM_Mosaico_Utils::processImg() (line 154 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: src in CRM_Mosaico_Utils::processImg() (line 213 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: extension in CRM_Mosaico_Utils::processImg() (line 217 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php).

Change History (7)

comment:1 Changed 3 years ago by JaimeV

Owner: set to JaimeV
Status: newassigned

We do have the imagemagick package installed but I think this extension needs the php5-imagick package to be installed. I've just added this to tresca. Let's see if that resolves the first issue. I am not sure about the other error messages.

comment:2 Changed 3 years ago by Liz Mestres

Thanks, but sadly there is no change.

comment:3 Changed 3 years ago by JaimeV

Cc: Jamie McClelland added

I'll copy jamie on this ticket, though I think it is good idea to reach out directly to the civicrm community for answers as well.

comment:4 Changed 3 years ago by Jamie McClelland

Can you try one more time? And if it fails, copy and paste the error message again? I just restarted php5-fpm - i think your running PHP process may not have known about the newly installed package.

comment:5 Changed 3 years ago by Liz Mestres

Great!, I don't get the "Imagemagick not installed" message and it seems to be working fine now.

It may not matter much but for some reason, I'm still getting the long message:

Notice: Undefined index: method in CRM_Mosaico_Utils::processImg() (line 149 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: params in CRM_Mosaico_Utils::processImg() (line 151 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined offset: 1 in CRM_Mosaico_Utils::processImg() (line 154 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: src in CRM_Mosaico_Utils::processImg() (line 213 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). Notice: Undefined index: extension in CRM_Mosaico_Utils::processImg() (line 217 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/CRM/Mosaico/Utils.php). User warning: Smarty error: unable to read resource: "CRM/common/wysiwyg.tpl" in Smarty->trigger_error() (line 1094 of /home/members/brechtforum/sites/gjc.brechtforum.org/web/sites/all/modules/civicrm/packages/Smarty/Smarty.class.php).

comment:6 Changed 3 years ago by JaimeV

Resolution: wontfix
Status: assignedfeedback

I think you'll need to get help with the Mosaico extension directly with its developers.

https://civicrm.org/extensions/email-template-builder https://github.com/voidlabs/mosaico/blob/master/README.md#are-you-having-issues-with-mosaico

The error regarding Smarty appears to be a misconfiguration problem with that plugin. http://www.smarty.net/forums/viewtopic.php?t=4500 https://github.com/pacercms/pacercms/issues/10

comment:7 Changed 3 years ago by automatic

Status: feedbackclosed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.