Opened 3 years ago

Closed 3 years ago

#11835 closed Bug/Something is broken (fixed)

email functionality

Reported by: Victor Manfredi Owned by: JaimeV
Priority: Medium Component: Tech
Keywords: Cc:
Sensitive: no

Description

hello, i've tested my mayfirst email address by sending a message from manfredi@… to alabriola@… while i'm logged into the latter in horde. the automatic copy is duly received at the bu.edu account, proving that the message was sent, but nothing arrives in the mayfirst.org account. thanks, victor

Change History (10)

comment:1 Changed 3 years ago by JaimeV

Owner: set to JaimeV
Status: newassigned

The e-mail alabriola@… is configured to forward all mail to manfredi@…. If you would like it to both be received locally and forwarded you can add include both the local user manfredi as well as the forwarding address in the list of recipients like so: "manfredi, manfredi@…"

comment:2 Changed 3 years ago by Victor Manfredi

correct, it is *supposed* to forward, and indeed it *used to* forward (up to a month ago, was the last occasion), but i tested it last night and again just a minute ago, and now it's not forwarding to the .edu account. in the past 30 days i have made no relevant changes either to mayfirst or bu account setup, moreover i've verified that the mayfirst is actively "whitelisted" in the bu filters, so i remain puzzled why no forwarding seems to be happening now.

comment:3 Changed 3 years ago by Victor Manfredi

i have now added the local user "manfredi" as well as "alabriola" (just in case it also helps?) and then sent a test message, but nothing shows up in the inbox (in either roundcube or horde), so there seems to be a problem with the email account which is not related to forwarding. this happened within the past month because i did receive a forwarded message from may1st account on 6 may. thanks, vm

comment:4 Changed 3 years ago by JaimeV

oh, no it seems my last reply was not properly sent. Form our logs I see that the destination server is accepting the e-mail forward. The established protocol between e-mail servers dictates that whenever the receiving server accepts a message for delivery it becomes their responsibility and the sending server can assume its job is finished.

I just sent a test mail to your address and see the following in the logs. The line that ends in "status=sent (250 2.0.0 u59JVbEW005916 Message accepted for delivery)" is the important message from server relay.bu.edu [128.197.228.151]

0 marx:~# grep C3C3A200A /var/log/mail.log
Jun  9 15:28:31 marx postfix/smtpd[12441]: C3C3A200A: client=paulo.mayfirst.org[162.247.75.145]
Jun  9 15:28:31 marx postfix/cleanup[19040]: C3C3A200A: message-id=<5759C40F.2010506@mayfirst.org>
Jun  9 15:28:31 marx postfix/qmgr[3063]: C3C3A200A: from=<jaimev@mayfirst.org>, size=1055, nrcpt=1 (queue active)
Jun  9 15:28:31 marx postfix/smtpd[19043]: EF01B2035: client=localhost[127.0.0.1], orig_queue_id=C3C3A200A, orig_client=paulo.mayfirst.org[162.247.75.145]
Jun  9 15:28:40 marx postfix/smtp[19041]: C3C3A200A: to=<alabriola@manfredi.mayfirst.org>, relay=127.0.0.1[127.0.0.1]:10026, delay=8.5, delays=0.11/0.02/0.06/8.4, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as EF01B2035)
Jun  9 15:28:40 marx postfix/qmgr[3063]: C3C3A200A: removed
0 marx:~# 
0 marx:~# 
0 marx:~# grep EF01B2035 /var/log/mail.log
Jun  9 15:28:31 marx postfix/smtpd[19043]: EF01B2035: client=localhost[127.0.0.1], orig_queue_id=C3C3A200A, orig_client=paulo.mayfirst.org[162.247.75.145]
Jun  9 15:28:40 marx postfix/cleanup[19040]: EF01B2035: message-id=<5759C40F.2010506@mayfirst.org>
Jun  9 15:28:40 marx postfix/qmgr[3063]: EF01B2035: from=<jaimev@mayfirst.org>, size=1562, nrcpt=2 (queue active)
Jun  9 15:28:40 marx postfix/smtp[19041]: C3C3A200A: to=<alabriola@manfredi.mayfirst.org>, relay=127.0.0.1[127.0.0.1]:10026, delay=8.5, delays=0.11/0.02/0.06/8.4, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as EF01B2035)
Jun  9 15:28:40 marx postfix/smtp[19047]: EF01B2035: to=<manfredi@bu.edu>, orig_to=<alabriola@manfredi.mayfirst.org>, relay=relay.bu.edu[128.197.228.151]:25, delay=8.8, delays=8.4/0.02/0.27/0.15, dsn=2.0.0, status=sent (250 2.0.0 u59JVbEW005916 Message accepted for delivery)
Jun  9 15:28:41 marx postfix/lmtp[19049]: EF01B2035: to=<manfredi@marx.mayfirst.org>, orig_to=<alabriola@manfredi.mayfirst.org>, relay=marx.mayfirst.org[private/dovecot-lmtp], delay=9.1, delays=8.4/0.02/0.01/0.71, dsn=2.0.0, status=sent (250 2.0.0 <manfredi@marx.mayfirst.org> 3gDkE5XCWVcOPAAASOZ7vg Saved)
Jun  9 15:28:41 marx postfix/qmgr[3063]: EF01B2035: removed
0 marx:~# 
0 marx:~# 
0 marx:~# grep 5759C40F.2010506@mayfirst.org /var/log/mail.log
Jun  9 15:28:31 marx postfix/cleanup[19040]: C3C3A200A: message-id=<5759C40F.2010506@mayfirst.org>
Jun  9 15:28:39 marx spampd[29492]: processing message <5759C40F.2010506@mayfirst.org> for <alabriola@manfredi.mayfirst.org> ORCPT=rfc822;alabriola@manfredi.mayfirst.org
Jun  9 15:28:40 marx spampd[29492]: clean message <5759C40F.2010506@mayfirst.org> (-1.43/5.00) from <jaimev@mayfirst.org> for <alabriola@manfredi.mayfirst.org> ORCPT=rfc822;alabriola@manfredi.mayfirst.org in 0.28s, 1095 bytes.
Jun  9 15:28:40 marx postfix/cleanup[19040]: EF01B2035: message-id=<5759C40F.2010506@mayfirst.org>
Jun  9 15:28:41 marx dovecot: lmtp(15374, manfredi): 3gDkE5XCWVcOPAAASOZ7vg: sieve: msgid=<5759C40F.2010506@mayfirst.org>: stored mail into mailbox 'INBOX'

Also above the line that ends in "stored mail into mailbox 'INBOX'" logs the moment when a local copy was delivered to the INBOX of user manfredi.

Last edited 3 years ago by JaimeV (previous) (diff)

comment:5 Changed 3 years ago by Victor Manfredi

the troubleshooting continues!

a few hours ago i deleted my may1st email address and then recreated it an hour later, hoping that this might reset whatever is wrong, but it has apparently not worked.

when i received the test message at bu account from jaime, i tried to send another test message from bu account to may1st account, and when i logged into may1st horde i could see that it was duly received there, HOWEVER it was not forwarded successfully. so then while still logged into horde on may1st, i tried to send a message to my bu account directly, not as a forward and surprise, as soon as i pressed "send" a red error message appeared in the bottom right corner of the window (which i was not fast enough to make a screenshot of before it disappeared), saying said that the message was not sent because of an error of "domain" -- no domain specified, or something of the kind. but the address specified in the email DID have a domain, namely bu.edu, so there is something wrong with my email send function on may1st.

comment:6 Changed 3 years ago by Victor Manfredi

getting warmer...

to control for the application, i have just successfully sent two messages from roundcube on may1st to my bu account. both of them were received at bu.

when i tried THE SAME thing from horde on may1st, i got the same red error flag, "missing domain" and nothing was either sent or received.

NOW, i would happily forget about horde and simply use roundcube EXCEPT that the forwarding function is still down. does this mean that forwarding is uniquely handled by horde? or is there a way to set up forwarding on roundcube independent of horde?

comment:7 Changed 3 years ago by JaimeV

The forwarding should be configured directly in the MFPL control panel, not through either Horde or Roundcube which are effectively just e-mail clients. In fact I would suggest you do continue to use Roundcube over Horde.

comment:8 Changed 3 years ago by Victor Manfredi

yes forwarding has ALWAYS been configured in the MPFL control panel, so the problem is located elsewhere.

let me try to summarise the situation at present.

  1. i have just verified that forwarding to bu.edu email address is correctly configured in MPFL control panel. it has ALWAYS been correctly configured, thus this was NEVER the source of the failure of forwarding.
  1. i have just verified that MFPL roundcube is able to send email to my bu.edu email address, and also to jaime's MFPL address.
  1. i have just verified that MFPL horde is still UNABLE to send mail to my bu.edu address, OR even to REPLY to an email which it has successfully received from my bu.edu address, giving on both cases the same red error message that "domain is missing". it ALSO fails to send to jaime's MFPL address, giving the same red error message, even though i'm replying to an email which was successfully received from jaime.
  1. i'm happy not to use horde ever, but the fact remains that forwarding does not work from my MFPL account. MAYBE the failure of forwarding is unrelated to the inability of MFPL horde to send any email to any address, but it seems like a coincidence, therefore i speculate that the cause of the forwarding failure could be related to the total failure of horde to send email to any address whatsoever.
  1. forwarding remains nonfunctional for now, despite point 1 above.

comment:9 Changed 3 years ago by JaimeV

Resolution: fixed
Status: assignedfeedback

Sorry, just had time to come back to this today. The error sending from Horde is related to not having a default identity created for your account which results to an error attempting to send to any address. https://support.mayfirst.org/wiki/faq/email/default-identity-horde

This is usually created automatically for you but under some conditions needs to be done manually. I've just done that for you.

However this IS in fact a separate issue from the forwarding issue..

I just sent another test message to alabriola@…. as the logs below indicate the message was promptly forwarded to manfredi@… and delivery was accepted by that e-mail server.

0 marx:~# grep 22EA12029: /var/log/mail.log
Jul  4 15:11:06 marx postfix/smtpd[31028]: 22EA12029: client=paulo.mayfirst.org[162.247.75.145]
Jul  4 15:11:06 marx postfix/cleanup[31350]: 22EA12029: message-id=<37d6c8bd-7fd6-8bcf-d63b-d7ac9bd56bc4@mayfirst.org>
Jul  4 15:11:06 marx postfix/qmgr[3063]: 22EA12029: from=<jaimev@mayfirst.org>, size=1059, nrcpt=1 (queue active)
Jul  4 15:11:06 marx postfix/smtp[31357]: 22EA12029: to=<alabriola@manfredi.mayfirst.org>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.41, delays=0.04/0/0.04/0.32, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 366A82032)
Jul  4 15:11:06 marx postfix/qmgr[3063]: 22EA12029: removed
0 marx:~# grep 366A82032 /var/log/mail.log
Jul  4 15:11:06 marx postfix/smtpd[31359]: 366A82032: client=localhost[127.0.0.1], orig_queue_id=22EA12029, orig_client=paulo.mayfirst.org[162.247.75.145]
Jul  4 15:11:06 marx postfix/cleanup[31360]: 366A82032: message-id=<37d6c8bd-7fd6-8bcf-d63b-d7ac9bd56bc4@mayfirst.org>
Jul  4 15:11:06 marx postfix/qmgr[3063]: 366A82032: from=<jaimev@mayfirst.org>, size=1580, nrcpt=2 (queue active)
Jul  4 15:11:06 marx postfix/smtp[31357]: 22EA12029: to=<alabriola@manfredi.mayfirst.org>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.41, delays=0.04/0/0.04/0.32, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 366A82032)
Jul  4 15:11:06 marx postfix/lmtp[31373]: 366A82032: to=<manfredi@marx.mayfirst.org>, orig_to=<alabriola@manfredi.mayfirst.org>, relay=marx.mayfirst.org[private/dovecot-lmtp], delay=0.44, delays=0.31/0/0/0.12, dsn=2.0.0, status=sent (250 2.0.0 <manfredi@marx.mayfirst.org> 9kcLKJa0eleOegAASOZ7vg Saved)
Jul  4 15:11:06 marx postfix/smtp[31973]: 366A82032: to=<manfredi@bu.edu>, orig_to=<alabriola@manfredi.mayfirst.org>, relay=relay.bu.edu[128.197.228.159]:25, delay=0.73, delays=0.31/0.02/0.21/0.19, dsn=2.0.0, status=sent (250 2.0.0 u64JEDJg023039 Message accepted for delivery)
Jul  4 15:11:06 marx postfix/qmgr[3063]: 366A82032: removed

Please try sending an e-mail to alabriola@… from any other e-mail address that is not your same bu.edu address. I suspect there may be some filtering going on as you are effctively sending to yourself from there.

comment:10 Changed 3 years ago by automatic

Status: feedbackclosed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.