Opened 3 years ago

Closed 3 years ago

#11628 closed Bug/Something is broken (fixed)

IMEMC site: 504 gateway timeout

Reported by: IMEMC Admin Owned by: JaimeV
Priority: Urgent Component: Tech
Keywords: Cc:
Sensitive: no

Description

Hi

We made our site on mayfirst.org live yesterday - and it is having huge problems. it keeps timing out with 504- gateway timeout

this is a big problem. this is a high-traffic site (1.5 - 2 million hits per month). it is also subjected to ddos attacks, so we have deflect.ca set up to run the dns

but I am wondering if mayfirst has the server capacity to deal with this site. I have had someone suggest that we go to cloudhosting - but I want to check in with mayfirst before that. either way we have to do something quick, the site is going offline every couple of minutes and we lose readership when that happens. the site is on floriberto.mayfirst.org it is http://www.imemc.org

Change History (4)

comment:1 Changed 3 years ago by JaimeV

Owner: set to JaimeV
Status: newassigned

Sorry for the delay, I am looking at this now. The site appears to be up now and your host floriberto.mayfirst.org does not appear to be overloaded at the moment. However I did find and fix a problem that could have been affecting your site yesterday. Since you are behind deflect now, most visits to your site will be directed to cached copies of your site on one of the deflect edge servers. Most visits to your site will never reach mayfirst directly. The deflect servers however will visit your site at mayfirst very often to update their copies of your site. We have some filtering in place with fail2ban meant to stop attacks on websites but fail2ban can confuse the aggressive caching servers with a real attack, and if the deflect servers get blocked they'll cache a timeout page for your site. To avoid this we usually exclude the sites we know are behind deflect from the filtering process. Your site had not been added to the exclude list. I've just done this now. Hopefully this will improve performance.

comment:2 Changed 3 years ago by Jamie McClelland

imemc has been moved to a dedicated server and is still experiencing this problem. We are currently working with deflect on the solution.

Since the last report of the problem I have moved the custom php.ini settings to the new host.

jamie

comment:3 Changed 3 years ago by JaimeV

Resolution: fixed
Status: assignedfeedback

comment:4 Changed 3 years ago by automatic

Status: feedbackclosed

No news is good news (we hope)! Given the lack of feedback, we think this ticket can be closed.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.