Opened 3 years ago

Closed 3 years ago

#11620 closed Bug/Something is broken (fixed)

DNS CNAME record not redirecting properly

Reported by: https://id.mayfirst.org/democorg Owned by: JaimeV
Priority: Medium Component: Tech
Keywords: DNS Cc: Jamie McClelland
Sensitive: no

Description

I set up a CNAME record to point democracyuprising.org to democracyuprising.com, however it seems to be getting redirected to malcolm.mayfirst.org instead.

Can you please assist?

Change History (5)

comment:1 Changed 3 years ago by JaimeV

Cc: Jamie McClelland added
Owner: set to JaimeV
Status: newassigned

It seems you had actually created an a record instead of a cname record. I think we generally discourage cname records for reasons jamie can probably better explain. If you just want to redirect your website democracyuprising.org to democracyuprising.com a better solution might be to use an a record to direct it to the same ip used for democracyuprising.com and add a serveralias for democracyuprising.org in the web configuration for democracyuprising.com

comment:2 Changed 3 years ago by https://id.mayfirst.org/democorg

I tried the A record method first and it didn't work either, which is why I have a CNAME record now. I will try what you suggest.

comment:3 Changed 3 years ago by https://id.mayfirst.org/democorg

I attempted the proposed fix and got the same result.

comment:4 Changed 3 years ago by JaimeV

It looks like you still had a leftover A record point the .org domain to floriberto, I disabled that and another entry you had within the .com DNS entries and, this is key, I added decmocracy.org as a server alias in your web configuration panel for decomocracy.org . Might take a little while for DNS changes to propagate but that should work.

comment:5 Changed 3 years ago by https://id.mayfirst.org/democorg

Resolution: fixed
Status: assignedclosed

Looks like it did, thanks for the assist.

Please login to add comments to this ticket.

Note: See TracTickets for help on using tickets.